[ubuntu/lucid] apt 0.7.25.3ubuntu2 (Accepted)

Michael Vogt michael.vogt at ubuntu.com
Mon Mar 15 09:11:46 GMT 2010


apt (0.7.25.3ubuntu2) lucid; urgency=low

  [ Michael Vogt ]
  * abicheck/
    - add new abitest tester using the ABI Compliance Checker from
      http://ispras.linuxfoundation.org/index.php/ABI_compliance_checker
  * debian/apt.conf.autoremove:
    - add "oldlibs" to the APT::Never-MarkAuto-Sections as its used
      for transitional packages
  * apt-pkg/deb/dpkgpm.cc:
    - fix backgrounding when dpkg runs (closes: #486222)
  * cmdline/apt-mark:
    - show error on incorrect aguments (LP: #517917), thanks to
      Torsten Spindler
  * cmdline/apt-get.cc:
    - if apt-get source foo=version or foo/distro can not be found,
      error out (LP: #502641)
  * apt-pkg/indexfile.cc:
    - deal correctly with three letter langcodes (LP: #391409)
  * debian/apt.cron.daily:
    - do not look into admin users gconf anymore for the http proxy
      the user now needs to use the "Apply system-wide" UI in the
      gnome-control-center to set it
  * debian/apt.postinst:
    - add set_apt_proxy_from_gconf() and run that once on upgrade if
      there is no proxy configured already system-wide (LP: #432631)
      From that point on gnome-control-center will have to warn if
      the user makes changes to the proxy settings and does not apply
      them system wide

  [ Robert Collins ]
  * Change the package index Info methods to allow apt-cache policy to be
    useful when using several different archives on the same host.
    (Closes: #329814, LP: #22354)

Date: Fri, 12 Mar 2010 23:10:52 +0100
Changed-By: Michael Vogt <michael.vogt at ubuntu.com>
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/lucid/+source/apt/0.7.25.3ubuntu2
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Fri, 12 Mar 2010 23:10:52 +0100
Source: apt
Binary: apt apt-doc libapt-pkg-dev libapt-pkg-doc apt-utils apt-transport-https
Architecture: source
Version: 0.7.25.3ubuntu2
Distribution: lucid
Urgency: low
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Michael Vogt <michael.vogt at ubuntu.com>
Description: 
 apt        - Advanced front-end for dpkg
 apt-doc    - Documentation for APT
 apt-transport-https - APT https transport
 apt-utils  - APT utility programs
 libapt-pkg-dev - Development files for APT's libapt-pkg and libapt-inst
 libapt-pkg-doc - Documentation for APT development
Closes: 329814 486222
Launchpad-Bugs-Fixed: 22354 391409 432631 502641 517917
Changes: 
 apt (0.7.25.3ubuntu2) lucid; urgency=low
 .
   [ Michael Vogt ]
   * abicheck/
     - add new abitest tester using the ABI Compliance Checker from
       http://ispras.linuxfoundation.org/index.php/ABI_compliance_checker
   * debian/apt.conf.autoremove:
     - add "oldlibs" to the APT::Never-MarkAuto-Sections as its used
       for transitional packages
   * apt-pkg/deb/dpkgpm.cc:
     - fix backgrounding when dpkg runs (closes: #486222)
   * cmdline/apt-mark:
     - show error on incorrect aguments (LP: #517917), thanks to
       Torsten Spindler
   * cmdline/apt-get.cc:
     - if apt-get source foo=version or foo/distro can not be found,
       error out (LP: #502641)
   * apt-pkg/indexfile.cc:
     - deal correctly with three letter langcodes (LP: #391409)
   * debian/apt.cron.daily:
     - do not look into admin users gconf anymore for the http proxy
       the user now needs to use the "Apply system-wide" UI in the
       gnome-control-center to set it
   * debian/apt.postinst:
     - add set_apt_proxy_from_gconf() and run that once on upgrade if
       there is no proxy configured already system-wide (LP: #432631)
       From that point on gnome-control-center will have to warn if
       the user makes changes to the proxy settings and does not apply
       them system wide
 .
   [ Robert Collins ]
   * Change the package index Info methods to allow apt-cache policy to be
     useful when using several different archives on the same host.
     (Closes: #329814, LP: #22354)
Checksums-Sha1: 
 38ad0d0477d6da73f1dd571fc43c41a13c678903 1350 apt_0.7.25.3ubuntu2.dsc
 eb6ec4384383808014232022c3fb2912ca7b81ff 2735618 apt_0.7.25.3ubuntu2.tar.gz
Checksums-Sha256: 
 0e60cf82adaa5990b2cf21c46924d9f5a119c1d67d40cbdcdf570cad730b9132 1350 apt_0.7.25.3ubuntu2.dsc
 9a931bcfc90738d28d3232a2e0dba0b17c1f95cae11d97a026756f14a0104e2c 2735618 apt_0.7.25.3ubuntu2.tar.gz
Files: 
 ed7512b43e2a1caba68cadfa2ebd6326 1350 admin important apt_0.7.25.3ubuntu2.dsc
 403f9e0fe3586f76ac6753627fcdeaa9 2735618 admin important apt_0.7.25.3ubuntu2.tar.gz
Original-Maintainer: APT Development Team <deity at lists.debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkuavMcACgkQliSD4VZixzRjRwCfTTmrjANa+2476lzzkTWNYTEQ
e8IAoKB9cpa1qWhMELhN2O34DpOPOYbB
=Lhlb
-----END PGP SIGNATURE-----


More information about the Lucid-changes mailing list