[ubuntu/lucid] perl 5.10.1-8ubuntu1 (Accepted)

Michael Bienia geser at ubuntu.com
Thu Jan 7 14:40:33 GMT 2010


perl (5.10.1-8ubuntu1) lucid; urgency=low

  * Merge with Debian testing (lp: #496556), remaining changes:
    - Add Breaks against doc-base (<< 0.8.16) to fix upgrade issues from
      hardy.
    - Change build dependency from libdb4.7-dev to libdb-dev, to minimize the
      db versions on the CDs.
    - On sparc, build with -O1 instead of -O2. See #438876.

perl (5.10.1-8) unstable; urgency=medium

  * Fix another perl-suid/i386 dependency bug by using dpkg-shlibdeps
    correctly. (Closes: #556847)
  * Add Conflicts/Replaces/Provides for libthread-queue-perl.
    (Closes: #556793)

perl (5.10.1-7) unstable; urgency=medium

  * Only run dpkg-shlibdeps when all the shlibs files have been created.
    This fixes perl-suid dependencies on i386. (Closes: #552797)
  * Set myself as Maintainer and remove Brendan O'Dea from the control
    file at his request.
  * Make the threads-shared test suite more robust, fixing failures on hppa.
    (Closes: #554218)

perl (5.10.1-6) unstable; urgency=high

  * Added /me to Uploaders.
  * Apply upstream fix to resolve some crash in pattern matching against
    non-Unicode tainted string. This fixes CVE-2009-3626. (Closes: #552291)

perl (5.10.1-5) unstable; urgency=low

  * Make DynaLoader work without Config_heavy.pl again. (Closes: #549170)

perl (5.10.1-4) unstable; urgency=low

  * Temporarily work around an internal compiler error in Devel::PPPort
    on ia64+gcc-4.3. (Closes: #548943)

perl (5.10.1-3) unstable; urgency=low

  * Upload to unstable.

perl (5.10.1-2) experimental; urgency=low

  * reinstate Debian change to ExtUtils::MakeMaker for now to allow
    overriding PREFIX at installation time again. (Closes: #545904)
  * Separate Archive::Tar instance error strings from each other.
    (Closes: #539355)
  * Fix a crash with \G on first match. (Closes: #545234)

perl (5.10.1-1) experimental; urgency=low

  * New upstream release.
  * Remove traces of libcpan-plus-perl provides/conflicts/replaces in favour
    of libcpanplus-perl.
  * Clean an accidentally duplicated libcpanplus-perl conflict entry.
  * Add conflicts/replaces/provides for
    + libio-compress-bzip2-perl
  * Don't test .ph file syntax when DEB_BUILD_OPTIONS contains "nocheck"
    or "x-perl-notest"
  * Replace /usr/share/doc symlinks with separate changelog and copyright
    files in the arch-independent packages (perl-doc and perl-modules)
    to make sure they correspond to the right package version.
    (Closes: #536384, #542137)
  * Add support for abstract sockets. Thanks to Lubomir Rintel.
    (Closes: #329291, #490660)
  * In versions older than 5.10.0-24, CPANPLUS system configuration would be
    erroneously saved under /usr/share. Avoid loss of local configuration by
    copying it to /etc/perl/CPANPLUS/Config/System.pm on upgrades before the
    new package overwrites it. (Closes: #543910)
  * Add gcc predefined macros to $Config{cppsymbols} on GNU/Hurd.
    Thanks to Samuel Thibault. (Closes: #544307)
  * Fix autodie on hppa by allowing for flock returning EAGAIN instead
    of EWOULDBLOCK. (Closes: #543731)
  * Move /usr/share/perl/5.10/unicore/To into perl-base. (See #543149)

perl (5.10.1~rc2-1) experimental; urgency=low

  * New upstream release candidate.
    + Archive::Tar now supports bzip2 files. (Closes: #457326)
    + Module::CoreList now includes ExtUtils::Miniperl. (Closes: #508696)
    + ExtUtils::Manifest now handles whitespace correctly. (Closes: #538005)
    + CGI.pm unwanted UTF-8 conversion in URLs is fixed. (Closes: #516129)
    + FileCache needs symbolic references, documentation updated.
      (Closes: #318579)
    + perldoc.pod now references perlpod.pod. (Closes: #479638)
    + Long regular expressions work again. (Closes: #527039)
    + File::Temp::tempfile now supports TMPDIR. (Closes: #351373)
    + File::Temp now works with ACLs. (Closes: #531770)
    + IPC::Cmd now works with arrayrefs. (Closes: #533380)
    + perlpod.pod documentation fix: =encoding affects the whole document.
      (Closes: #527023)
    + CPAN.pm no longer passes make arguments through to Build.
      (Closes: #508183)
    + using the same lexically scoped variable in a foreach loop twice
      no longer segfaults. (Closes: #511589)
    + unwanted filehandle stringification in CGI.pm is fixed. (Closes: #483144)
    + script_name() in CGI.pm is fixed. (Closes: #493965)
    + revision information removed from perlfaq whatis entries
      (Closes: #402046)
  * Updated the conflicts list for the various dual-lived modules.
  * Added conflicts/replaces/provides for
    + libio-compress-perl
    + libcompress-raw-bzip2-perl
    + libthreads-perl
    + libthreads-shared-perl
    + libparse-cpan-meta-perl
    + libparent-perl
    + libautodie-perl
  * Update the search path in the h2ph check. Thanks to Marius Vollmer.
  * Build-Depend on libbz2-dev instead of using the bundled library in
    ext/Compress-Raw-Bzip2.

perl (5.10.0-25) unstable; urgency=low

  * Fix File::Copy::copy with pipes on GNU/kFreeBSD.
    Thanks to Petr Salinger. (Closes: #537555)
  * Module::Build::Compat makefiles now support 'distclean'.
    Thanks to Ryan Niebur. (Closes: #527993)
  * Honor TMPDIR when open()ing an anonymous temporary file.
    Thanks to Norbert Buchmuller. (Closes: #528544)
  * Move to libdb4.7. (Closes: #536443)

Date: Mon, 14 Dec 2009 14:18:19 +0100
Changed-By: Michael Bienia <geser at ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Signed-By: Matthias Klose <matthias.klose at canonical.com>
https://launchpad.net/ubuntu/lucid/+source/perl/5.10.1-8ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Mon, 14 Dec 2009 14:18:19 +0100
Source: perl
Binary: perl-base libcgi-fast-perl perl-doc perl-modules perl-debug perl-suid libperl5.10 libperl-dev perl
Architecture: source
Version: 5.10.1-8ubuntu1
Distribution: lucid
Urgency: high
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Michael Bienia <geser at ubuntu.com>
Description: 
 libcgi-fast-perl - CGI::Fast Perl module
 libperl-dev - Perl library: development files
 libperl5.10 - shared Perl library
 perl       - Larry Wall's Practical Extraction and Report Language
 perl-base  - minimal Perl system
 perl-debug - debug-enabled Perl interpreter
 perl-doc   - Perl documentation
 perl-modules - Core Perl modules
 perl-suid  - runs setuid Perl scripts
Closes: 318579 329291 351373 402046 457326 479638 483144 490660 493965 508183 508696 511589 516129 527023 527039 527993 528544 531770 533380 536384 536443 537555 538005 539355 542137 543731 543910 544307 545234 545904 548943 549170 552291 552797 554218 556793 556847
Changes: 
 perl (5.10.1-8ubuntu1) lucid; urgency=low
 .
   * Merge with Debian testing (lp: #496556), remaining changes:
     - Add Breaks against doc-base (<< 0.8.16) to fix upgrade issues from
       hardy.
     - Change build dependency from libdb4.7-dev to libdb-dev, to minimize the
       db versions on the CDs.
     - On sparc, build with -O1 instead of -O2. See #438876.
 .
 perl (5.10.1-8) unstable; urgency=medium
 .
   * Fix another perl-suid/i386 dependency bug by using dpkg-shlibdeps
     correctly. (Closes: #556847)
   * Add Conflicts/Replaces/Provides for libthread-queue-perl.
     (Closes: #556793)
 .
 perl (5.10.1-7) unstable; urgency=medium
 .
   * Only run dpkg-shlibdeps when all the shlibs files have been created.
     This fixes perl-suid dependencies on i386. (Closes: #552797)
   * Set myself as Maintainer and remove Brendan O'Dea from the control
     file at his request.
   * Make the threads-shared test suite more robust, fixing failures on hppa.
     (Closes: #554218)
 .
 perl (5.10.1-6) unstable; urgency=high
 .
   * Added /me to Uploaders.
   * Apply upstream fix to resolve some crash in pattern matching against
     non-Unicode tainted string. This fixes CVE-2009-3626. (Closes: #552291)
 .
 perl (5.10.1-5) unstable; urgency=low
 .
   * Make DynaLoader work without Config_heavy.pl again. (Closes: #549170)
 .
 perl (5.10.1-4) unstable; urgency=low
 .
   * Temporarily work around an internal compiler error in Devel::PPPort
     on ia64+gcc-4.3. (Closes: #548943)
 .
 perl (5.10.1-3) unstable; urgency=low
 .
   * Upload to unstable.
 .
 perl (5.10.1-2) experimental; urgency=low
 .
   * reinstate Debian change to ExtUtils::MakeMaker for now to allow
     overriding PREFIX at installation time again. (Closes: #545904)
   * Separate Archive::Tar instance error strings from each other.
     (Closes: #539355)
   * Fix a crash with \G on first match. (Closes: #545234)
 .
 perl (5.10.1-1) experimental; urgency=low
 .
   * New upstream release.
   * Remove traces of libcpan-plus-perl provides/conflicts/replaces in favour
     of libcpanplus-perl.
   * Clean an accidentally duplicated libcpanplus-perl conflict entry.
   * Add conflicts/replaces/provides for
     + libio-compress-bzip2-perl
   * Don't test .ph file syntax when DEB_BUILD_OPTIONS contains "nocheck"
     or "x-perl-notest"
   * Replace /usr/share/doc symlinks with separate changelog and copyright
     files in the arch-independent packages (perl-doc and perl-modules)
     to make sure they correspond to the right package version.
     (Closes: #536384, #542137)
   * Add support for abstract sockets. Thanks to Lubomir Rintel.
     (Closes: #329291, #490660)
   * In versions older than 5.10.0-24, CPANPLUS system configuration would be
     erroneously saved under /usr/share. Avoid loss of local configuration by
     copying it to /etc/perl/CPANPLUS/Config/System.pm on upgrades before the
     new package overwrites it. (Closes: #543910)
   * Add gcc predefined macros to $Config{cppsymbols} on GNU/Hurd.
     Thanks to Samuel Thibault. (Closes: #544307)
   * Fix autodie on hppa by allowing for flock returning EAGAIN instead
     of EWOULDBLOCK. (Closes: #543731)
   * Move /usr/share/perl/5.10/unicore/To into perl-base. (See #543149)
 .
 perl (5.10.1~rc2-1) experimental; urgency=low
 .
   * New upstream release candidate.
     + Archive::Tar now supports bzip2 files. (Closes: #457326)
     + Module::CoreList now includes ExtUtils::Miniperl. (Closes: #508696)
     + ExtUtils::Manifest now handles whitespace correctly. (Closes: #538005)
     + CGI.pm unwanted UTF-8 conversion in URLs is fixed. (Closes: #516129)
     + FileCache needs symbolic references, documentation updated.
       (Closes: #318579)
     + perldoc.pod now references perlpod.pod. (Closes: #479638)
     + Long regular expressions work again. (Closes: #527039)
     + File::Temp::tempfile now supports TMPDIR. (Closes: #351373)
     + File::Temp now works with ACLs. (Closes: #531770)
     + IPC::Cmd now works with arrayrefs. (Closes: #533380)
     + perlpod.pod documentation fix: =encoding affects the whole document.
       (Closes: #527023)
     + CPAN.pm no longer passes make arguments through to Build.
       (Closes: #508183)
     + using the same lexically scoped variable in a foreach loop twice
       no longer segfaults. (Closes: #511589)
     + unwanted filehandle stringification in CGI.pm is fixed. (Closes: #483144)
     + script_name() in CGI.pm is fixed. (Closes: #493965)
     + revision information removed from perlfaq whatis entries
       (Closes: #402046)
   * Updated the conflicts list for the various dual-lived modules.
   * Added conflicts/replaces/provides for
     + libio-compress-perl
     + libcompress-raw-bzip2-perl
     + libthreads-perl
     + libthreads-shared-perl
     + libparse-cpan-meta-perl
     + libparent-perl
     + libautodie-perl
   * Update the search path in the h2ph check. Thanks to Marius Vollmer.
   * Build-Depend on libbz2-dev instead of using the bundled library in
     ext/Compress-Raw-Bzip2.
 .
 perl (5.10.0-25) unstable; urgency=low
 .
   * Fix File::Copy::copy with pipes on GNU/kFreeBSD.
     Thanks to Petr Salinger. (Closes: #537555)
   * Module::Build::Compat makefiles now support 'distclean'.
     Thanks to Ryan Niebur. (Closes: #527993)
   * Honor TMPDIR when open()ing an anonymous temporary file.
     Thanks to Norbert Buchmuller. (Closes: #528544)
   * Move to libdb4.7. (Closes: #536443)
Checksums-Sha1: 
 4e2eac43ad4aa687f598731f4a5181b0246b6def 1461 perl_5.10.1-8ubuntu1.dsc
 8536ed1c14444d1efea069525a816fbc7be7109f 14117518 perl_5.10.1.orig.tar.gz
 1f682c4818987ee02ad2b812ebdc50b8456e68fe 101975 perl_5.10.1-8ubuntu1.diff.gz
Checksums-Sha256: 
 639bf1b63692a84e9033b684c5a0cff9980a0979cc0f4c2105d4c1d4d554b16a 1461 perl_5.10.1-8ubuntu1.dsc
 cb7f26ea4b2b28d6644354d87a269d01cac1b635287dae64e88eeafa24b44f35 14117518 perl_5.10.1.orig.tar.gz
 97d42675d8c78456322c9909addfb4134420b91cf9ee03990d7de69063adddd4 101975 perl_5.10.1-8ubuntu1.diff.gz
Files: 
 defef909a318fa30ad455f764619a93f 1461 perl standard perl_5.10.1-8ubuntu1.dsc
 b9b2fdb957f50ada62d73f43ee75d044 14117518 perl standard perl_5.10.1.orig.tar.gz
 f296430b8c8a7d00bbb55379acf64300 101975 perl standard perl_5.10.1-8ubuntu1.diff.gz
Original-Maintainer: Niko Tyni <ntyni at debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAktF8e8ACgkQStlRaw+TLJxCIgCcD5LgvZ/8NE+Gwf47Zu3xfVQ4
m58An0aOYObd3e8RV6332LXwha/IHqOd
=10EJ
-----END PGP SIGNATURE-----


More information about the Lucid-changes mailing list