[ubuntu/lucid] pootle 2.0.0-2 (Accepted)

Ubuntu Installer archive at ubuntu.com
Mon Jan 4 20:17:33 GMT 2010


pootle (2.0.0-2) unstable; urgency=low

  * debian/rules: Removed language ca at valencia. It currently blocks upgrades.

pootle (2.0.0-1) unstable; urgency=low

  [ Nicolas François ]
  * New upstream release
  * debian/rules: Cleanup. Removed commented code.
  * debian/contrib/cPootle: Removed. It does not apply anymore to the new
    version of Pootle.
  * debian/pootle.example: Removed debian/pootle.conf. The apache
    configuration should be updated.

  [ Rail Aliev ]
  Changes introduced in 1.3.0~beta4-1~ppa1:
  * debian/compat: Bumped to 7
  * debian/control:
    - Drop python-kid dependency.
    - Depend on libjs-jquery instead of internal one.
    - Updated debhelper build dependency
    - Depend on ${misc:Depends}
  * debian/rules:
    - Use debhelper 7 features to simplify the rules.
    - Remove upstream INSTALL file.
    - Remove duplicated COPYING file.
    - Use symlinked jquery.min.js from libjs-jquery instead of internal.
    - Remove unused debian/pootle.lintian-overrides and not needed
      debian/pootle.docs files.
  * debian/copyright: Do not mention where the license is located in the
    source package.
  * debian/pootle.dirs: Removed usr/share/lintian/overrides

pootle (2.0.0~rc2-1) UNRELEASED; urgency=low

  * New upstream release
  * debian/control: Updated version dependency of translate-toolkit to 1.5.0
  * debian/patches/packaging_install_outside_rootdir.patch: Disabled. The
    patched code was commented out upstream.

pootle (2.0.0~rc1-1) UNRELEASED; urgency=low

  * New upstream release
  * debian/patches/import_old_config.patch: Disabled. Bug fixed upstream and
    import of activation keys is not necessary.
  * debian/pootle.postinst: Fix import of project. The project directories
    need to be moved from /var/lib/pootle to /var/lib/pootle/po
  * debian/NEWS: Warn about this move of data files.

pootle (1.3.0~beta3-1) UNRELEASED; urgency=low

  * New beta upstream release
  * debian/control: Depend on python-django instead of python-jtoolkit
  * debian/control: python-django is a Pre-Depends since it is needed to
    configure the database.
  * debian/pootle.examples: The new configuration is localsettings.py. Removed
    Pootle/pootle.prefs and Pootle/users.prefs.
  * debian/patches/series:
    + debian/patches/debian_system_installation.patch: Removed. Another Debian
      customization might be needed, but it will be very different.
    + packaging_install_outside_rootdir.patch: When installing in a temporary
      root directory to prepare a package, the paths in localsettings.py are
      invalid. (--prefix should be checked.
    + debian/patches/import_old_config.patch: activationcode is now
      activation_key and is in the profile table, not user.
    + removed all patches. They should be re-checked.
  * debian/pootle.docs: There is no Pootle directory anymore.
  * debian/pootle.init: With the new version, start-stop-daemon needs to do
    the daemonization and creation of the pidfile.
  * debian/rules
    + new setup file
    + Cleanup should be updated
    + The new setup rules install files in the expected locations.
    + There is no Pootle directory anymore.
    + Run dh_pycentral with --noscripts because some code is needed between
      the dh_pycentral and dh_installinit blocks in the postinst script.
  * debian/pootle.postinst: Updated to the new /var/lib layout
  * debian/pootle.postinst: Configure the pootle database on installation and
    try to import users during updates.
  * debian/README.Debian: Update some Debian specific documentation.

pootle (1.2.1-4) unstable; urgency=low

  * debian/patches/translate_toolkit_1_4.patch: Fix failures with the new
    translate toolkit version (1.4).
  * debian/control: Standards-Version bumped to 3.8.3.
  * debian/pootle.dirs: do not distribute var/run/pootle. This is created by
    the init script.

Date: Mon,  04 Jan 2010 19:35:28 +0000
Changed-By: Charlie_Smotherman (porthose) <cjsmo at cableone.net>
Maintainer: Nicolas FRANCOIS (Nekral) <nicolas.francois at centraliens.net>
Origin: Debian/unstable
https://launchpad.net/ubuntu/lucid/+source/pootle/2.0.0-2
-------------- next part --------------
Origin: Debian/unstable
Format: 1.7
Date: Mon,  04 Jan 2010 19:35:28 +0000
Source: pootle
Binary: pootle
Architecture: source
Version: 2.0.0-2
Distribution: lucid
Urgency: low
Maintainer: Nicolas FRANCOIS (Nekral) <nicolas.francois at centraliens.net>
Changed-By: Charlie_Smotherman (porthose) <cjsmo at cableone.net>
Description: 
 pootle     - Web-based translation and translation management tool
Changes: 
 pootle (2.0.0-2) unstable; urgency=low
 .
   * debian/rules: Removed language ca at valencia. It currently blocks upgrades.
 .
 pootle (2.0.0-1) unstable; urgency=low
 .
   [ Nicolas François ]
   * New upstream release
   * debian/rules: Cleanup. Removed commented code.
   * debian/contrib/cPootle: Removed. It does not apply anymore to the new
     version of Pootle.
   * debian/pootle.example: Removed debian/pootle.conf. The apache
     configuration should be updated.
 .
   [ Rail Aliev ]
   Changes introduced in 1.3.0~beta4-1~ppa1:
   * debian/compat: Bumped to 7
   * debian/control:
     - Drop python-kid dependency.
     - Depend on libjs-jquery instead of internal one.
     - Updated debhelper build dependency
     - Depend on ${misc:Depends}
   * debian/rules:
     - Use debhelper 7 features to simplify the rules.
     - Remove upstream INSTALL file.
     - Remove duplicated COPYING file.
     - Use symlinked jquery.min.js from libjs-jquery instead of internal.
     - Remove unused debian/pootle.lintian-overrides and not needed
       debian/pootle.docs files.
   * debian/copyright: Do not mention where the license is located in the
     source package.
   * debian/pootle.dirs: Removed usr/share/lintian/overrides
 .
 pootle (2.0.0~rc2-1) UNRELEASED; urgency=low
 .
   * New upstream release
   * debian/control: Updated version dependency of translate-toolkit to 1.5.0
   * debian/patches/packaging_install_outside_rootdir.patch: Disabled. The
     patched code was commented out upstream.
 .
 pootle (2.0.0~rc1-1) UNRELEASED; urgency=low
 .
   * New upstream release
   * debian/patches/import_old_config.patch: Disabled. Bug fixed upstream and
     import of activation keys is not necessary.
   * debian/pootle.postinst: Fix import of project. The project directories
     need to be moved from /var/lib/pootle to /var/lib/pootle/po
   * debian/NEWS: Warn about this move of data files.
 .
 pootle (1.3.0~beta3-1) UNRELEASED; urgency=low
 .
   * New beta upstream release
   * debian/control: Depend on python-django instead of python-jtoolkit
   * debian/control: python-django is a Pre-Depends since it is needed to
     configure the database.
   * debian/pootle.examples: The new configuration is localsettings.py. Removed
     Pootle/pootle.prefs and Pootle/users.prefs.
   * debian/patches/series:
     + debian/patches/debian_system_installation.patch: Removed. Another Debian
       customization might be needed, but it will be very different.
     + packaging_install_outside_rootdir.patch: When installing in a temporary
       root directory to prepare a package, the paths in localsettings.py are
       invalid. (--prefix should be checked.
     + debian/patches/import_old_config.patch: activationcode is now
       activation_key and is in the profile table, not user.
     + removed all patches. They should be re-checked.
   * debian/pootle.docs: There is no Pootle directory anymore.
   * debian/pootle.init: With the new version, start-stop-daemon needs to do
     the daemonization and creation of the pidfile.
   * debian/rules
     + new setup file
     + Cleanup should be updated
     + The new setup rules install files in the expected locations.
     + There is no Pootle directory anymore.
     + Run dh_pycentral with --noscripts because some code is needed between
       the dh_pycentral and dh_installinit blocks in the postinst script.
   * debian/pootle.postinst: Updated to the new /var/lib layout
   * debian/pootle.postinst: Configure the pootle database on installation and
     try to import users during updates.
   * debian/README.Debian: Update some Debian specific documentation.
 .
 pootle (1.2.1-4) unstable; urgency=low
 .
   * debian/patches/translate_toolkit_1_4.patch: Fix failures with the new
     translate toolkit version (1.4).
   * debian/control: Standards-Version bumped to 3.8.3.
   * debian/pootle.dirs: do not distribute var/run/pootle. This is created by
     the init script.
Files: 
 6bd34fe9a0076ef1881a4fa5560853d1 1287 python optional pootle_2.0.0-2.dsc
 bc405934f30ffe41418461c68cd52848 3939813 python optional pootle_2.0.0.orig.tar.gz
 6e584ce2835d4fd531365141d8ed4720 21394 python optional pootle_2.0.0-2.diff.gz


More information about the Lucid-changes mailing list