[ubuntu/lucid] mono 2.4.4~svn151842-1ubuntu1 (Accepted)

Alexander Sack asac at ubuntu.com
Fri Feb 26 13:05:25 GMT 2010


mono (2.4.4~svn151842-1ubuntu1) lucid; urgency=low

  [ Iain Lane <laney at ubuntu.com> ]
  * Merge from Debian unstable, remaining changes:
    + fix mono ftbfs with thumb2 on armel; use gcc atomic built-ins. Please
      note that this change has been applied in the Debian packaging branch,
      so should be dropped after the next upload there. (LP: #525063)

  [ Alexander Sack <asac at ubuntu.com> ]
  * mono-thumb2-jit-blx.dpatch, 00list: add fix for more thumb2
    porting issues (LP: #514215)

mono (2.4.4~svn151842-1) unstable; urgency=medium

  [ Jo Shields ]
  * debian/patches/dont_assert_on_empty_DGC_field_r146984.dpatch:
    + Backport fix from upstream which causes IKVM to fail to build
      (Closes: #562393)
  * debian/patches/escape_Lucene.Net_search_string_r148946.dpatch:
    + Backport fix from upsrream which causes Monodoc to crash when
      searching for "()" and other characters (Closes: #516597)

  [ Mirco Bauer ]
  * The "Mono 2.4.4 FREE LUV for squeeze & lucid" release
  * New upstream SVN snapshot of the mono-2-4 branch
    + Fixed assertion failed in fieldref_encode_signature which caused
      SIGABRT. (Closes: #565548)
    + Mono is now DFSG complaint again by default as the binary-only shipped
      files were replaced with source code. Also the non-free XML
      specification files were replaced and thus we can ship the RabbitMQ
      library again.
  * debian/patches/disable_building_convert.exe.dpatch
    debian/patches/disable_building_RabbitMQ.Client.dll.dpatch:
    + Dropped, we can build the RabbitMQ client library and convert.exe again,
      as the source is provided now (see above).
  * debian/fix_large_ranges_in_random_generator_r146995.dpatch:
    + Dropped, already applied upstream.
  * debian/watch:
    + We are only watching the 2.4 series for now (until squeeze is released)
  * debian/control:
    + Added libnunit-cil-dev to Depends of libmono-cil-dev as that one
      contains the symlink to the nunit.pc file which is no longer present in
      libnunit2.4-cil but libnunit-cil-dev.
    + Dropped purpose less libmono-nunit2.4-cil package as libmono-cil-dev
      does the job now.
    + Added conflicts libmono-nunit2.4-cil to libmono-cil-dev for cleaning up.
    + Shortened too long line in the long descroption of libmono-cil-dev.
    + Changed section of libmono-dev to libdevel.
    + Added ${misc:Depends} to Depends of all packages.
    + Bumped Standards-Version to 3.8.4 (no changes needed).
    + Re-added libmono-messaging-rabbitmq2.0-cil and libmono-rabbitmq2.0-cil
      packages.
  * debian/cli.binfmt:
    + Replaced mono-common with mono-runtime. (Closes: #565490)
  * debian/mono-runtime.postinst:
    + Removed obsolete mono-common / mono-jit traces.
  * debian/copyright:
    + Refere to versioned GPL license file.
    + Updated license information of RabbitMQ XML specification files.
    + Added license information of docs/HtmlAgilityPack.

Date: Mon, 22 Feb 2010 23:51:28 +0100
Changed-By: Alexander Sack <asac at ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/lucid/+source/mono/2.4.4~svn151842-1ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Mon, 22 Feb 2010 23:51:28 +0100
Source: mono
Binary: mono-runtime mono-runtime-dbg mono-utils mono-complete libmono0 libmono0-dbg libmono-dev libmono-profiler libmono-cil-dev libmono1.0-cil libmono2.0-cil libmono-posix1.0-cil libmono-posix2.0-cil libmono-getoptions1.0-cil libmono-getoptions2.0-cil libmono-cecil-private-cil libmono-data1.0-cil libmono-data2.0-cil libmono-c5-1.0-cil libmono-webbrowser0.5-cil libmono-management2.0-cil libmono-messaging2.0-cil libmono-messaging-rabbitmq2.0-cil libmono-rabbitmq2.0-cil libmono-simd2.0-cil libmono-corlib1.0-cil libmono-corlib2.0-cil libmono-i18n-west1.0-cil libmono-i18n-west2.0-cil libmono-i18n1.0-cil libmono-i18n2.0-cil libmono-system1.0-cil libmono-system2.0-cil libmono-system-messaging1.0-cil libmono-system-messaging2.0-cil libmono-security1.0-cil libmono-security2.0-cil libmono-data-tds1.0-cil libmono-data-tds2.0-cil libmono-system-data1.0-cil libmono-system-data2.0-cil libmono-system-web1.0-cil libmono-system-web2.0-cil libmono-system-web-mvc1.0-cil libmono-wcf3.0-cil libmono-system-runtime1.0-cil
 libmono-system-runtime2.0-cil libmono-system-ldap1.0-cil libmono-system-ldap2.0-cil libmono-winforms1.0-cil libmono-winforms2.0-cil libmono-cairo1.0-cil libmono-cairo2.0-cil libmono-sharpzip0.6-cil libmono-sharpzip0.84-cil libmono-sharpzip2.6-cil libmono-sharpzip2.84-cil libmono-npgsql1.0-cil libmono-npgsql2.0-cil libmono-bytefx0.7.6.1-cil libmono-bytefx0.7.6.2-cil libmono-firebirdsql1.7-cil libmono-db2-1.0-cil libmono-oracle1.0-cil libmono-oracle2.0-cil libmono-sqlite1.0-cil libmono-sqlite2.0-cil libmono-accessibility1.0-cil libmono-accessibility2.0-cil libmono-cscompmgd7.0-cil libmono-cscompmgd8.0-cil libmono-ldap1.0-cil libmono-ldap2.0-cil libmono-microsoft-build2.0-cil libmono-microsoft7.0-cil libmono-microsoft8.0-cil libmono-peapi1.0-cil libmono-peapi2.0-cil libmono-relaxng1.0-cil libmono-relaxng2.0-cil mono-dbg mono-mjs mono-mcs mono-gmcs mono-devel mono-1.0-devel mono-2.0-devel mono-1.0-service mono-2.0-service mono-xbuild mono-gac mono-1.0-gac mono-2.0-gac mono-jay
 prj2make-sharp mono-csharp-shell monodoc-base monodoc-manual
Architecture: source
Version: 2.4.4~svn151842-1ubuntu1
Distribution: lucid
Urgency: medium
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Alexander Sack <asac at ubuntu.com>
Description: 
 libmono-accessibility1.0-cil - Mono Accessibility library (for CLI 1.0)
 libmono-accessibility2.0-cil - Mono Accessibility library (for CLI 2.0)
 libmono-bytefx0.7.6.1-cil - Mono ByteFX.Data library (for CLI 1.0)
 libmono-bytefx0.7.6.2-cil - Mono ByteFX.Data library (for CLI 2.0)
 libmono-c5-1.0-cil - Mono C5 library
 libmono-cairo1.0-cil - Mono Cairo library (for CLI 1.0)
 libmono-cairo2.0-cil - Mono Cairo library (for CLI 2.0)
 libmono-cecil-private-cil - Mono.Cecil library
 libmono-cil-dev - Mono Base Class Libraries (BCL) - Development files
 libmono-corlib1.0-cil - Mono core library (for CLI 1.0)
 libmono-corlib2.0-cil - Mono core library (for CLI 2.0)
 libmono-cscompmgd7.0-cil - Mono cscompmgd library (for CLI 1.0)
 libmono-cscompmgd8.0-cil - Mono cscompmgd library (for CLI 2.0)
 libmono-data-tds1.0-cil - Mono Data library (for CLI 1.0)
 libmono-data-tds2.0-cil - Mono Data Library (for CLI 2.0)
 libmono-data1.0-cil - Mono.Data.* libraries (for CLI 1.0)
 libmono-data2.0-cil - Mono.Data.* libraries (for CLI 2.0)
 libmono-db2-1.0-cil - Mono DB2 library
 libmono-dev - Mono JIT library - Development files
 libmono-firebirdsql1.7-cil - Mono FirebirdSql library
 libmono-getoptions1.0-cil - Mono.GetOptions library (for CLI 1.0)
 libmono-getoptions2.0-cil - Mono.GetOptions library (for CLI 2.0)
 libmono-i18n-west1.0-cil - Mono I18N.West library (for CLI 1.0)
 libmono-i18n-west2.0-cil - Mono I18N.West library (for CLI 2.0)
 libmono-i18n1.0-cil - Mono I18N libraries (for CLI 1.0)
 libmono-i18n2.0-cil - Mono I18N libraries (for CLI 2.0)
 libmono-ldap1.0-cil - Mono LDAP library (for CLI 1.0)
 libmono-ldap2.0-cil - Mono LDAP library (for CLI 2.0)
 libmono-management2.0-cil - Mono Management library (for CLI 2.0)
 libmono-messaging-rabbitmq2.0-cil - Mono Messaging RabbitMQ library (for CLI 2.0)
 libmono-messaging2.0-cil - Mono Messaging library (for CLI 2.0)
 libmono-microsoft-build2.0-cil - Mono Microsoft.Build libraries
 libmono-microsoft7.0-cil - Mono Microsoft libraries (for CLI 1.0)
 libmono-microsoft8.0-cil - Mono Microsoft libraries (for CLI 2.0)
 libmono-npgsql1.0-cil - Mono Npgsql library (for CLI 1.0)
 libmono-npgsql2.0-cil - Mono Npgsql library (for CLI 2.0)
 libmono-oracle1.0-cil - Mono Oracle library (for CLI 1.0)
 libmono-oracle2.0-cil - Mono Oracle library (for CLI 2.0)
 libmono-peapi1.0-cil - Mono PEAPI library (for CLI 1.0)
 libmono-peapi2.0-cil - Mono PEAPI library (for CLI 2.0)
 libmono-posix1.0-cil - Mono.Posix library (for CLI 1.0)
 libmono-posix2.0-cil - Mono.Posix library (for CLI 2.0)
 libmono-profiler - Mono profiler libraries
 libmono-rabbitmq2.0-cil - Mono RabbitMQ.Client library (for CLI 2.0)
 libmono-relaxng1.0-cil - Mono Relaxng library (for CLI 1.0)
 libmono-relaxng2.0-cil - Mono Relaxng library (for CLI 2.0)
 libmono-security1.0-cil - Mono Security library (for CLI 1.0)
 libmono-security2.0-cil - Mono Security library (for CLI 2.0)
 libmono-sharpzip0.6-cil - Mono SharpZipLib library (for CLI 1.0)
 libmono-sharpzip0.84-cil - Mono SharpZipLib library (for CLI 1.0)
 libmono-sharpzip2.6-cil - Mono SharpZipLib library (for CLI 2.0)
 libmono-sharpzip2.84-cil - Mono SharpZipLib library (for CLI 2.0)
 libmono-simd2.0-cil - Mono SIMD (for CLI 2.0)
 libmono-sqlite1.0-cil - Mono Sqlite library (for CLI 1.0)
 libmono-sqlite2.0-cil - Mono Sqlite library (for CLI 2.0)
 libmono-system-data1.0-cil - Mono System.Data library (for CLI 1.0)
 libmono-system-data2.0-cil - Mono System.Data Library (for CLI 2.0)
 libmono-system-ldap1.0-cil - Mono System.DirectoryServices library (for CLI 1.0)
 libmono-system-ldap2.0-cil - Mono System.DirectoryServices library (for CLI 2.0)
 libmono-system-messaging1.0-cil - Mono System.Messaging library (for CLI 1.0)
 libmono-system-messaging2.0-cil - Mono System.Messaging Library (for CLI 2.0)
 libmono-system-runtime1.0-cil - Mono System.Runtime library (for CLI 1.0)
 libmono-system-runtime2.0-cil - Mono System.Runtime Library (for CLI 2.0)
 libmono-system-web-mvc1.0-cil - Mono ASP.NET MVC Library
 libmono-system-web1.0-cil - Mono System.Web library (for CLI 1.0)
 libmono-system-web2.0-cil - Mono System.Web Library (for CLI 2.0)
 libmono-system1.0-cil - Mono System libraries (for CLI 1.0)
 libmono-system2.0-cil - Mono System libraries (for CLI 2.0)
 libmono-wcf3.0-cil - Mono WCF libraries (for CLI 2.0)
 libmono-webbrowser0.5-cil - Mono Web Browser library
 libmono-winforms1.0-cil - Mono System.Windows.Forms library (for CLI 1.0)
 libmono-winforms2.0-cil - Mono System.Windows.Forms library (for CLI 2.0)
 libmono0   - Mono JIT library
 libmono0-dbg - Mono JIT library, debugging symbols
 libmono1.0-cil - Mono libraries (for CLI 1.0)
 libmono2.0-cil - Mono libraries (for CLI 2.0)
 mono-1.0-devel - Mono development tools for CLI 1.0
 mono-1.0-gac - Mono GAC tool (for CLI 1.0)
 mono-1.0-service - Mono service manager for CLI 1.0
 mono-2.0-devel - Mono development tools for CLI 2.0
 mono-2.0-gac - Mono GAC tool (for CLI 2.0)
 mono-2.0-service - Mono service manager for CLI 2.0
 mono-complete - complete Mono runtime, development tools and all libraries
 mono-csharp-shell - interactive C# shell
 mono-dbg   - Mono debugging symbols
 mono-devel - Mono development tools
 mono-gac   - Mono GAC tool
 mono-gmcs  - Mono C# 2.0 and C# 3.0 compiler for CLI 2.0
 mono-jay   - LALR(1) parser generator oriented to Java/CLI
 mono-mcs   - Mono C# 1.0 compiler for CLI 1.1
 mono-mjs   - Mono JScript compiler
 mono-runtime - Mono runtime
 mono-runtime-dbg - Mono runtime, debugging symbols
 mono-utils - Mono utilities
 mono-xbuild - MSBuild-compatible build system for Mono
 monodoc-base - shared MonoDoc binaries
 monodoc-manual - compiled XML documentation from the Mono project
 prj2make-sharp - Convert VS.NET solution files to Makefiles
Closes: 516597 562393 565490 565548
Launchpad-Bugs-Fixed: 514215 525063
Changes: 
 mono (2.4.4~svn151842-1ubuntu1) lucid; urgency=low
 .
   [ Iain Lane <laney at ubuntu.com> ]
   * Merge from Debian unstable, remaining changes:
     + fix mono ftbfs with thumb2 on armel; use gcc atomic built-ins. Please
       note that this change has been applied in the Debian packaging branch,
       so should be dropped after the next upload there. (LP: #525063)
 .
   [ Alexander Sack <asac at ubuntu.com> ]
   * mono-thumb2-jit-blx.dpatch, 00list: add fix for more thumb2
     porting issues (LP: #514215)
 .
 mono (2.4.4~svn151842-1) unstable; urgency=medium
 .
   [ Jo Shields ]
   * debian/patches/dont_assert_on_empty_DGC_field_r146984.dpatch:
     + Backport fix from upstream which causes IKVM to fail to build
       (Closes: #562393)
   * debian/patches/escape_Lucene.Net_search_string_r148946.dpatch:
     + Backport fix from upsrream which causes Monodoc to crash when
       searching for "()" and other characters (Closes: #516597)
 .
   [ Mirco Bauer ]
   * The "Mono 2.4.4 FREE LUV for squeeze & lucid" release
   * New upstream SVN snapshot of the mono-2-4 branch
     + Fixed assertion failed in fieldref_encode_signature which caused
       SIGABRT. (Closes: #565548)
     + Mono is now DFSG complaint again by default as the binary-only shipped
       files were replaced with source code. Also the non-free XML
       specification files were replaced and thus we can ship the RabbitMQ
       library again.
   * debian/patches/disable_building_convert.exe.dpatch
     debian/patches/disable_building_RabbitMQ.Client.dll.dpatch:
     + Dropped, we can build the RabbitMQ client library and convert.exe again,
       as the source is provided now (see above).
   * debian/fix_large_ranges_in_random_generator_r146995.dpatch:
     + Dropped, already applied upstream.
   * debian/watch:
     + We are only watching the 2.4 series for now (until squeeze is released)
   * debian/control:
     + Added libnunit-cil-dev to Depends of libmono-cil-dev as that one
       contains the symlink to the nunit.pc file which is no longer present in
       libnunit2.4-cil but libnunit-cil-dev.
     + Dropped purpose less libmono-nunit2.4-cil package as libmono-cil-dev
       does the job now.
     + Added conflicts libmono-nunit2.4-cil to libmono-cil-dev for cleaning up.
     + Shortened too long line in the long descroption of libmono-cil-dev.
     + Changed section of libmono-dev to libdevel.
     + Added ${misc:Depends} to Depends of all packages.
     + Bumped Standards-Version to 3.8.4 (no changes needed).
     + Re-added libmono-messaging-rabbitmq2.0-cil and libmono-rabbitmq2.0-cil
       packages.
   * debian/cli.binfmt:
     + Replaced mono-common with mono-runtime. (Closes: #565490)
   * debian/mono-runtime.postinst:
     + Removed obsolete mono-common / mono-jit traces.
   * debian/copyright:
     + Refere to versioned GPL license file.
     + Updated license information of RabbitMQ XML specification files.
     + Added license information of docs/HtmlAgilityPack.
Checksums-Sha1: 
 8eb1f02bd7f2f7d27b1a7207186e1aa9eb0c18c1 4462 mono_2.4.4~svn151842-1ubuntu1.dsc
 dc32c1f771af9d81bb799781c33e5596a8eb4847 33348749 mono_2.4.4~svn151842.orig.tar.gz
 ca2b080605c4a873bdf1962ed816dc6ba8403897 274433 mono_2.4.4~svn151842-1ubuntu1.diff.gz
Checksums-Sha256: 
 21191b093852809fa0eeabeae9fa699afcb314269d0ea38accd24e6210402718 4462 mono_2.4.4~svn151842-1ubuntu1.dsc
 595ab2f37685b13534ca0ea3df119a96afca7a721686cb1a6744c75982e7f6d6 33348749 mono_2.4.4~svn151842.orig.tar.gz
 6f42e3c5cb78228cc238ae6685e62188657dbcbe731fc0e7e4b88acc9aa33242 274433 mono_2.4.4~svn151842-1ubuntu1.diff.gz
Files: 
 e8e26ee414d3d02e67924b8c22295ecc 4462 cli-mono optional mono_2.4.4~svn151842-1ubuntu1.dsc
 45178e6ea677852806fcfbf26ec9f1fc 33348749 cli-mono optional mono_2.4.4~svn151842.orig.tar.gz
 5a4da436577c0eb310bc4618122d1d3a 274433 cli-mono optional mono_2.4.4~svn151842-1ubuntu1.diff.gz
Original-Maintainer: Debian Mono Group <pkg-mono-group at lists.alioth.debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iQIcBAEBAgAGBQJLh8JWAAoJEKBE/gcUDGZkMB4P/RZXK5o0/IglkYL8s52QwSVN
igi6RyrE6qSwtczdFBKk/VJbCBMaWBO6/X4LOSQBxxfE9mg8G5LCcWUA1uyUJMfR
g7XYySE1p4De57nLXsD6ysjlHFTWAelqKhPTcgZyBRLK3LE+nL0enSopyzm3DnOD
6kd8UbLHO+lZKb5lMhfjdwFSrpk7BzF31IfwHjbn183JhNzCqmpQWwE2Rn0ikZ1U
L0N3t81Sr+xsJ1AgpHbCZkx1iw5CAPxgnbN+L/VcTE7ppb9qTTsZ+GEPzCcCBXk7
5ynbovX3NvFUrMhiZigNJ7VGiIrJgBDA5KzL5O5/2XNVVCfPNAhJy0V7rFd1sWn+
j08DYeBZ20Pzlw8kWXt6A3Lpxd514UaHS4LdBLvQY7h9qV64XzzEod6R+G8/6LwN
ViZ3aBjjiFc9uoaKVrx5Ql+dcnwZZM0oZeziWrD0OtxsZ25MEE9SujWtdEvdDdvH
9S+ZF+VVEV+G46Alhqg/wPdHYrsqFnOjTrvJVnxwh2go62OcjQXDXA5/gLiADjGD
BRf39ztTZUSkysXJi+r1ABrZDo6MD2oZo8ZCPaFIvFQnBllzYiby8/ndl5l11GmP
e4BVz3m3zd2v7JM/8fEbZQHv0WdCWGPYYCNupkz/1DyUxVh7aPTZRmgD+nHtNT9s
NiK9+FJb2rqSmvnBwWp9
=pr23
-----END PGP SIGNATURE-----


More information about the Lucid-changes mailing list