I would like to give some feedback on a user's experience trying to download and install Lubuntu, if I may.<div><br></div><div>It's hard to find the download page. Clicking on "Get Ubuntu" takes  you to the help page. Then you have to rummage around on the site to find somewhere to actually download the version you need.</div>
<div><br></div><div>When you do select to download, it gives you v12.04. Even after rummaging around not possible to see any other versions to download.</div><div><br></div><div>The help page talks about other versions. It's information implies that 11.10 is the long-term release. But there appears to be nowhere to download the long-term release. The importance of short-term releases became apparent to users recently when, for example, they got shipwrecked with the short term release of Ubuntu before the Unity overhaul. Had they stuck with the long term release prior to that, they would not now be shipwrecked. Yes I am speaking from experience. But what's the point of having a long-term release if you don't make it clear to users that this is the most advisable version to download and then point them to it?</div>
<div><br></div><div>The checksum info page contains info only about 11.10 checksums. But the site downloads 12.04.</div><div><br></div><div>The checksum and torrent additions to the download process have really snarled things up for idiot users - sorry, you can't say that, can you? It's snarled things up for 'dummies'. No, you can't say that either, can you? Just because you are not an experienced command-line user, administrator or nerd hobbyist, that doesn't make you a dummy. But you are likely to have plenty else to do: looking after kids, working over-time, fixing the car, fending off zombies. So the install process requires that you learn about torrent clients and command lines and checksums. That's the last thing I need to do. That's eliminated most of the population of the planet as potential users straight off. Point and click, man. What's with all these complications?</div>
<div><br></div><div>So anyway. What I needed: a guarantee that I've got a version that will work with the target machine: PIII, 256Mb; a long term release version; and on the advice of this website, a checksummed version. What I got: likelihood the version I've got doesn't work with my machine, a short term release version, and no checksum validation.</div>
<div><br></div><div>On top of all that, I'm dizzy from going back and forth and round the website for the information I need to perform this simplest of operations: downloading a version to install.</div><div><br></div>
<div> </div>