[lubuntu-users] What happened?? kernel not upgrading during dist-upgrade in kinetic??

Fritz Hudnut este.el.paz at gmail.com
Sun Sep 11 18:45:34 UTC 2022

Top posting:

This is the current data from Lubuntu, and that UUID number doesn't show up
anywhere in "sudo blkid" from in the Lu system.  But I did write that
number down from some "error" reports showing in the console during the
last apt dist-upgrade that I ran yesterday in Lu.  Somehow perhaps apt did
something to  mess itself up??

[CODE] sudo cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'


Do I want to edit that "quiet splash resume" data to match the /dev/sdc7
location of the Lubuntu "/" UUID??

[CODE] /dev/sdc7: UUID="17bcb813-d05e-4cc3-bcdf-16d283156780"  [/CODE]

And, then try to again run the grub bootloader to get it to find a newer
location of Lu that would then allow upgrading to 5.19 xx kernel???



On Sat, Sep 10, 2022 at 5:05 PM Fritz Hudnut <este.el.paz at gmail.com> wrote:

> Welp . . . not getting it . . . .  I ran mainline to --install-latest
> and it installed 5.19.5 kernel.  It said on the console, "reboot to select
> new kernel."  Rebooted over to TW and ran "grub2-mkconfig xxxxxxx" to get
> it to run os-prober and make a new grub . . . .  Shut down.  Cold booted to
> grub and selected Lu . . . and still running kernel is 5.13 . . . ???
> I tried to uninstall oldest kernel but mainline said, "error: can't find
> running kernel."  Ssked mainline to list the kernels and then it showed
> 5.13 as "running" . . . and there are two 5.19 kernel options showing as
> installed in the list???
> I had a similar type of problem with Pop_OS! at one point, where they use
> the /efi/boot partition to install the kernel . . . and it over-filled the
> directory with kernels . . . and couldn't get grub to select the newer
> kernel . . . .  Turned out there, there was hardware issues . . . it all
> got rather "complicated" after a lot of messing around.  Here I saw
> somewhere in apt it was saying "trying to boot from /dev/sdc9" . . . and
> that is a swap partition . . . .
> Couldn't find my notes on how to show uuid  in efibootmgr to see what is
> showing up there.  Perhaps I'll use mainline to remove the 5.19 kernels and
> see then the next time if apt dist-upgrade will upgrade the kernel???
> F

> On Sat, Sep 10, 2022 at 11:55 AM Nio Wiklund <nio.wiklund at gmail.com>
>> wrote:
>>> Hi Fritz,
>>> This is what I think:
>>> If the active grub is controlled by some other distro in a dual-boot or
>>> multi-boot setup,
>>> sudo update-grub
>>> of Lubuntu will not upgrade which kernel it points to. You should boot
>>> into the system that controls the active grub and run
>>> sudo update-grub
>>> or some corresponding command. Chances are that it will make Lubuntu
>>> boot into the 5.19 kernel.
>>> Best regards
>>> Nio
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/lubuntu-users/attachments/20220911/e963a095/attachment.html>

More information about the Lubuntu-users mailing list