[lubuntu-users] Lubuntu 20.04

Aere Greenway aere at dvorak-keyboards.com
Thu Apr 30 21:20:12 UTC 2020

On 4/30/20 10:53 AM, Olle Wiklund wrote:
> Den 2020-04-30 kl. 18:49, skrev Aere Greenway:
>> On 4/30/20 10:39 AM, Nio Wiklund wrote:
>>> Den 2020-04-30 kl. 18:21, skrev Aere Greenway:
>>>> Lubuntu Users:
>>>> I recently upgraded a Lubuntu 19.10 system to 20.04, and it has 
>>>> worked so well, I have actually made it my production system.
>>>> There were some 'rough edges', but I was able to get around them.
>>>> I am using the LXDE desktop with it, for familiarity and 
>>>> customization reasons.
>>>> If I could customize the look-and-feel of the LXQT desktop more, I 
>>>> might start using that.
>>>> But a big thing I notice, is that I have installed software from 
>>>> the Ubuntu repository (Chromium, for example), yet it doesn't 
>>>> appear anywhere in the application menu/launcher - not even in the 
>>>> Debian area.
>>>> What do I need to do to make the software I've installed, appear in 
>>>> the menu?
>>>> It is possible I installed the software when I was experimenting 
>>>> with the LXQT desktop.
>>>> I tried re-installing while in the LXDE desktop, but it still 
>>>> doesn't appear in the menu anywhere.
>>> Hi Aere,
>>> Long time no see :-)
>>> How do you install your program packages? Is Chromium installed as a 
>>> snap? And what about the other programs?
>>> When I install mkusb, its desktop files in
>>> /usr/share/applications
>>> will be recognized and added to the menu automatically.
>>> Best regards
>>> Nio
>> Chromium Web Browser is in /usr/share/applications, yet it doesn't 
>> appear in the menu anywhere.
>> I can run it using menu...Run...chromium
>> - Aere
> Check if the ownership and permissions of the desktop file are the 
> same as for the other desktop files that work.
> What is the content of the the Exec line in the desktop file? Does it 
> match what you use manually?
> Best regards
> Nio

By the way, chromium does appear in the menu, when using the Lubuntu 
(LXQT) desktop.  It just doesn't appear in the menu on the LXDE desktop.

I tried the following in the LXDE desktop.

I checked the ownership and permissions of chromium-browser in /usr/bin, 
and they are the same as things I can execute from the menu.

I purged (completely removed) chromium using the muon package manager, 
and removed chromium using Discover (which uses snap packages).

Then I installed it using Discover.

Chromium did not appear in the menu.

I installed chromium using Synaptic Package Manager.  It still didn't 
appear in the LXDE menu.

I was able to create a link to chromium-browser (in /usr/bin) in the 
Desktop folder, so now I at least have a non-typing way of running 
chromium on the LXDE desktop.


More information about the Lubuntu-users mailing list