[lubuntu-users] On Lubuntu 18.04, is a 32-bit /home compatible with a 64-bit home?

Aere Greenway Aere at Dvorak-Keyboards.com
Fri Jun 8 23:03:29 UTC 2018

On 06/04/2018 05:31 PM, Walter Lapchynski wrote:
> On Mon, Jun 04, 2018 at 04:30:52PM -0600, Aere Greenway wrote:
>> I'm thinking of switching my 32-bit Lubuntu to 64-bit, when I go to 18.04
> I think this is wise. In case you haven't heard the rumblings about
> ubuntu-release and ubuntu-devel, there's much talk of dropping 32 bit.
> In fact, most flavors have opted to drop it. Lubuntu is seriously
> considering following suit.
> Do note, though, that despite the potential for dropping it as a release
> architecture, 32 bit packages will likely live on for a long time.
>> My idea is to restore (including hidden files) my 32-bit Lubuntu 16.04.4
>> /home directory, to a new Lubuntu 18.04 64-bit system.
> I think this is the best solution, though I have not tested it. I had a
> multiarch system set up, where I was running a 64 bit kernel but had a
> menagerie of 32 and 64 bit userland that had all sorts of dependency
> issues. I probably could have bothered to ultimately fix it, but it
> would have been much more headache than what I wanted. Ultimately, I
> gave up on it and installed a new system. I actually restored only the
> /home files (especially configs) that I needed, after the new system was
> installed. The advantage of this is that if something about the format
> or options of the config files changed in the upgrade, I wasn't stuck
> trying to figure that out.
> Let us know how it goes!


I first tried Lubuntu 18.04 32-bit, which I got working for the most 
part.  My Kindle reader did not work after restoring everything.  But 
more critical to me, is the fact that the Eclipse development 
environment crashes during initialization, and won't initialize.

Researching the problem suggested that I use Oracle Java 8.1 via a PPA, 
which I tried, but that alone caused me even greater problems, so I 
abandoned the attempt, without even trying the install of a newer level 
of Eclipse.

My next step was to try 64-bit Lubuntu 16.04.4.  It appeared to restore 

But it hasn't worked entirely, and the part that didn't work, is 
critical to me.

Though everything else seems alive and working - including my Kindle 
reader, the Eclipse development environment I use for Java and C/C++ 
development, hangs during initialization.

So it looks like in order to use the new, reliable disk drive, I'll have 
to install 32-bit Lubuntu 16.04.4 (which is what I'm now using), and 
restore my home directory to that system.

The Windows partition is another matter entirely.

In spite of dutifully making a system image backup, and also a backup of 
files, the system restore DVD does not allow me to restore to a new 
drive (even with the original drive entirely gone).  So all that was a 
waste of time.

I did manage to clone the Windows partition (along with the other two 
partitions associated with it), to the new drive using gparted, and it 
boots and runs okay.

However, when I attempted to apply Windows updates, at the very end of 
the (long) process, it said it couldn't apply updates, and has to remove 
the updates it just applied, which puts it in an infinite update-failure 

It looks like I'll just have to keep using the systems on the old drive 
until the drive fails.

So much for trying to get ahead of the problem...


More information about the Lubuntu-users mailing list