[lubuntu-users] [lubuntu-devel] How to install Lubuntu Cosmic

Nio Wiklund nio.wiklund at gmail.com
Tue Jul 10 06:14:20 UTC 2018

Hi Simon,

[replying inline]

Best regards

Den 2018-07-09 kl. 20:36, skrev Simon Quigley:
> Hi Nio,
> On 07/09/2018 09:50 AM, Nio Wiklund wrote:
>> I tried to install Lubuntu Cosmic from the 64-bit daily iso file (dated
>> July 7). I failed after trying in several ways to install it via a USB
>> pendrive (cloned with mkusb), a DVD disk (burned and verified with k3b).
>> Several different errors were displayed, depending on what options I
> tried.
> It would be great if you could get the error logs from those.

During the next few days I will try to run several test cases and report 
bugs if/when I find new ones.

>> The target was my Toshiba laptop with Intel i5 (generation 3), that I
>> have used to test Lubuntu since 2013. It seems to me that Calamares does
>> not work, at least not as it is bundled in Lubuntu Cosmic right now.
> How did you launch Calamares? Right now, you need to go to the start
> menu and search "Install System" which should launch it. If not, type
> `sudo calamares` (yes, sudo, pkexec doesn't work and sudo doesn't break
> anything in this case) in QTerminal.

I started Calamares via the start menu.

I have not yet tried 'sudo calamares'

> <snip />> If *you* can install Lubuntu Cosmic with Calamares, please
> describe with
>> details, how to select options in the different steps, and tell me if
>> there are other things to consider, for example about the computer
>> (hardware components and settings).
> You just go through the install like normal.

This is what I have tried (and Calamares fails). I have tried different 
options, and 'nothing' has worked so far. I have 'only' tried in real 
computers, not in any virtual machine.

But installing from the Ubuntu mini.iso (also 64-bits) was successful. 
The result was a working Lubuntu installed system (without zram).

> The only thing I haven't tested yet is Secure Boot, so if you have error
> messages from that, it would be great if you could file a bug with them
> against calamares-settings-ubuntu.

Yes, I can try UEFI mode and secure boot in my Toshiba laptop from 2013, 
and report whatever result I get.
> Thanks.

More information about the Lubuntu-users mailing list