Re: Lubuntu 14 && U-MATE 15 installer issues [PPC]

Peter Golis golisp at centrum.sk
Wed May 13 17:15:07 UTC 2015


Hello Fritz,
is good to hear about your successfull recovery for yaboot.
 
Regarding mentioned other points:
1) Backdoor: This is normal for any OS installation which does not have secure boot nor encrypted disks.This is not limited to Lubuntu, Linux. This can be also in Windows, OS/2, Solaris and other OSes.
2) Network: Lot of Apple hardware have wired connection using sungem driver which work fine for lot of years to me. Wireless network on some devices can require switch to legacy driver as is described in howto.
3) Resize of NewWorld bootblock: this partition is usually sized like old floppy in Apple, and it must have old HFS file system additionally blessed with bootable mark and OFI need to know which file can be used as boot loader (yaboot or grub). There is no reason why to have it bigger as this is not /boot. I have used approx 200k from 1M.
4) Sound: you need to load module snd-aoa-i2sbus during boot. If this will not create alsa sound device, then you will need folow some kernel patching as not all of Apple sound cards was migrated from snd-powermac to snd-aoa. Mac Mini have correctly migrated toonie card, but white PowerBook6,3 (800MHz) had not correctly migrated tas sound card and recompilation of kernel is required. This is limitation of upstream.
 
Points 2, 3 and 4 are cleanly described in PowerPC FAQ. But we can agree one thing. Those PowerPC FAQ are not solution, those FAQ are only workarounds.
 
P.
 
______________________________________________________________
> Od: Fritz Hudnut <este.el.paz at gmail.com>
> Komu: Peter Golis <golisp at centrum.sk>
> Dátum: 13.05.2015 17:13
> Predmet: Re: Lubuntu 14 && U-MATE 15 installer issues [PPC]
>
> CC: "lubuntu user list"


On Wed, May 13, 2015 at 1:23 AM, Peter Golis <golisp at centrum.sk <golisp at centrum.sk>> wrote:
Hello Fritz,
Did you had try to press "c" before chime will play during boot initial sequence with loaded PowerPC bootable medium, or do you want only to discuss about that problem without any try to fix your deleted yaboot after you had deleted "NewWorld bootblock"?
 
I will recommend Lubuntu 14.04(.02) Mac (PowerPC) and IBM-PPC (POWER5) desktop image to be burn onto CD/DVD and used for that task. Your choice with Super Grub looks good as is based on GRUB. GRUB support PowerPC with boot from Open Firmware (IEEE 1275-1994), but Super Grub was not tested ieee1275. So, your choice was wrong.
 
P.
 
Peter:

Definitely my choice was, as you so aptly and succinctly put it . . . wrong.  But, I have to move forward and not beat myself up about it, because it's done . . . .  I've been had, bro . . . .  : - )))

Latest update:  I'm absolving myself of culpability in the matter and suggesting that there is some "bug" at work in 15.04; if I get the time I will try to report it . . . but, then this is PPC.  Evidence:   Yesterday evening I was able to boot the install DVD holding the "c" key before the chime, and I fiddled around with some apps, and was able to open a TTY from the desktop image--both things I couldn't do from the install.

Then I tried to boot into the install, Yaboot windows opens and I hit "L" and just for good measure I added the "video=ofonly radeon.agpmodexxxx" boot params.  We got to the U-MATE splash, then a "dmesg" like log opens which runs through a few [OK] and then freezes at "Starting Authenticate and Authorize Users to run privileged tasks . . . p link was shut down."  And it freezes there . . . still can't get to TTY once that happens.

Shut the unit down rebooted--went in through the back door as single user, which I believe possibly another bug, logged me in as root w/o asking for password???  I'll have to check that one again, as I was frantically trying to "fix" my problem I didn't care.  I ran my "ybin -v"  and saw the "blessing this w/penguin pee" . . . I opened the Yaboot.conf file and saw that my radeon append line was indeed there.  I opened the /etc/X11/xorg.conf file and saw that it was there . . . I ran "systemctl default" . . . it said it was in "rescue mode" . . . rebooted, and it went back into the freeze.

Back into single user, tried to run apt-get update and it showed a bunch of errors . . . failure to connect . . . aha, so we are back into the "network manager" bug from awhile back . . . some things never change.  I tried to "ping google.com <http://google.com>"  and message not received.  Then I ran out of time.  So, the whole thing is a tad weird . . . somehow apt can "see" that upgrades are available, including a kernel, and I recall seeing "dhcp" listed . . . but trying to run the upgrade fails . . . ?????  How does it "know" stuff is available for upgrade????  if it can't connect???? 

So, next step will be to try to repair the ethernet in 15.04 . . . which worked in the live desktop, and is working now back in OSX . . . and then see if I can run the upgrades.  I'll play around with it for a bit, does seem to be quite buggy, if it wasn't for the fact that I get a kick out of the GNOME floating feet screensaver I would and possibly will drop back to 14.04.  I hadn't planned on moving my PPC stuff beyond 14.04, it was only because the install didn't work using Lu 14.04 "manual" that I tried 15.04 . . . .   15 ***might** be fixable with my limited skills and wrong choices . . . or not worth it.

F 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/lubuntu-users/attachments/20150513/25e73fcb/attachment.html>


More information about the Lubuntu-users mailing list