Re: Lubuntu 14 && U-MATE 15 installer issues [PPC]

Peter Golis golisp at centrum.sk
Tue May 12 07:34:12 UTC 2015


Hello Fritz,
As first, you need to understood how boot on PowerPC architecture work, and also what is bad on same label "/" for different disks if mount is defined by label (not by UUID nor device file). And, also how to make propper "NewWorld bootblock" partition with correct FS, attributes and content. This partition is not like /boot, this is just bootloader stage used as jump from open firmware wuth defined booting path.
 
I had tested Lubuntu 14.04 installer for PowerPC on iBook G4 and it was working fine. Also, I had tested Ubuntu 12.04 installer for PowerPC on the same machine, and it was working fine. And finally, I had successfully tested ancient PowerPC Ubuntu on my Mac Mini lot of years ago when Ubuntu ShipIt was alive.
 
If your try to boot from cdrom was without success, please review what error it was and additionally check your keyboard. If you are using external keyboard, then you wull need to be sure to have that keyboard initialized before chime will play and you need to have it plugged into correct USB port. If keyboard will not be able to send keypress to open firmware, then defined boot sequence will be activated. In your case, that boot will fail as you dont have correctly created that bootblock after redesign of disk layout.
 
OFI and yaboot have recovery mode. When I had reinstalled my Mac Mini, I had used it. After HW crash (HDD was dead after allmost 10 years uptime, and cd was also not able to read lot of media), I had decided to use installation using manual debootstrap on different computer with installing base with lubuntu-desktop, kernel package and yaboot package. I had simply booted into open firmware, and activated boot of yaboot to start linux kernel with correct root partition. Once system had booted, I had done yaboot manual reconfiguration and hook of boot path for yaboot into OFI by ybin command.
 
PS: I cannot understood which error of installer did you had mean. Hooking of boot path into OFI to call yaboot and later also linux kernel is not part of manual partitioning. This is part of yaboot post installation step (configuration).
 
Also, I cannot inderstood what did you mean by pressing "L" during boot. This key used for booting Linux is part of yaboot, not open firmware. And yaboot is what you had successfully removed from boot sequence. Yaboot have also option to boot from "C"drom, optionally boot from "N"etwork and boot back to "O"pen firmware, but my suggestion to press "c" was before chime will play. This will say dirrectly to OFI to activate direct boot from CDROM without yaboot.
 
______________________________________________________________
> Od: Fritz Hudnut <este.el.paz at gmail.com>
> Komu: Peter Golis <golisp at centrum.sk>
> Dátum: 11.05.2015 23:10
> Predmet: Re: Lubuntu 14 && U-MATE 15 installer issues [PPC]
>
> CC: "lubuntu user list", "∅"
@wxl:

Thanks for the reply . . . indeed, the discussion I saw, couple talking heads . . . has nothing to do with this problem . . . but then I didn't hear them say "Snappy" either . . . but I only gave them about 5 minutes to access the focus of their effort.

@Peter:

Thanks also for your thoughts . . . however, past efforts to "boot open firmware" to try to boot a USB flash edition based upon the PowerPCFAQ instructions were ***not successful**** for my '04 era iBook G4 . . . well, I was able to boot into open firmware . . . but none of the supplied options on the FAQ did anything . . . and that included something like  "//yaboot"???? that was trying to boot the yaboot file in the USB flash . . . .  Point being, that I would need detailed directions on how to try that . . . and possibly that machine would not comply.

In terms of the "boot with c key" to boot the cdrom, right, that should have worked, but didn't . . . it went to the Yaboot window, and then selecting "c" for cdrom . . . brought some error . . . might have then been able to hit "return" and then tried "L" . . . leading to the frozen dmesg??? list, OR I can reboot into OSX . . . .

My thought is to again try to boot the linux install disk and try to run the install again and see if it "recognizes" anything as "installed" . . . and then tries to repair . . . .  To the best of my knowledge Yaboot doesn't have a "recovery" mode like GRUB does . . . .  Or . . . if that fails . . . "nuke and pave" . . . once again.  

One way or another, it isn't per se the install that is the issue, I got the system installed . . . and could probably do it again.  It's just the fact that using my usual "manual" partition method did not work . . . and possibly this may relate to some of these recent "installer" issues????

F
On Mon, May 11, 2015 at 1:11 PM, Peter Golis <golisp at centrum.sk <golisp at centrum.sk>> wrote:
Hello Fritz,
you can start open firmware and start yaboot from that small disk formated by UFS which is called new world boot. 

Alternatively you can insert LiveCD for PowerPC and startup that computer to boot from cdrom. There shall be enough to press/hold key "c" to tell OFI to boot from cdrom. Rest can be done using chroot.

Fritz Hudnut <este.el.paz at gmail.com <este.el.paz at gmail.com>> wrote:

Folks:

Just a little follow-up on the installer issue(s) . . . tried to watch the recent Hangouts on the installer on the world Ubuntu meeting, but didn't seem to be on point and at that time I hadn't tried to run an install.  Over the weekend I tried to install two flavors from desktop image burned to DVD on my iBook G4 . . . first it was Lubuntu 14.04 LTS that I had burned and I believe I installed and from memory downloaded in February.

I followed my usual style of selecting "something else" from the choice as I run a dual boot, set up a 10 MB "new world boot" partition, 12 GB formatted "ext4"  . . . and 2x RAM at 1380MB for swap . . . ran through the usual ID & password stuff . . . and the installer opened and started with "saving files xxx" . . . .  15 minutes later it was "still doing that" which ordinarily the install should be finishing or almost.  Checked GParted, boot partition showed 9MB installed, and ext4 showed 322MB . . . ????  Deleted the partitions and tried again . . . same thing . . . .  So I assumed that somehow the Lubuntu installer issues that have been discussed here had "migrated" into my burned DVD by magic . . . so I went on to try for a Ubuntu-MATE 15 iso . . . many downloads later I had a correct checksum number and burned it to DVD.  

The next day, yesterday I went for the install, this time I noticed that when I set up the Newworld boot it was flagged as "/" . . . and I also flagged the ext4 partition as "/" as I usual do for prior successful installs . . . running the install brought the same "saving copies" . . . with the same 9MB in newworld and 322MB showing as "used" . . . sensing a pattern I tried to delete the newworld partition, but, it would not run w/o it.  Then I tried to remove the "/" from the neworld, also not accepted . . . same thing when I tried to remove the "/" from the ext 4 partition.

So, I gave up on trying to use "something else" and I deleted all the partitions to "free space" and ran it as "install alongside OSX" . . . and it went through, Yaboot was installed . . . .  However, on reboot it went to a black screen, my radeon boot params were not carried over to the install . . . so I tried to set up an Xorg.conf and at same time add the boot params to the Yaboot.conf file . . . and botched the deal by forgetting (I believe) to run "sudo ybin" . . . and on reboot it went to the verbose log . . . ending with "p link is down" and it froze there.

I tried to boot a Super Grub2 CD but Yaboot would not boot it . . . so, problems with install, work around that "fixed it," and then I screwed it up . . . seems par for the course for the iBook lately . . . .  

Clearly there are "issues" with the "something else" way of installing with possibly the double flag for "/" being involved?  If there is a bug report for this issue, happy to add my name to it.  Might have time in a few days to try to run the installer over my install and see if it "dpkg" the problem . . . ah, I also tried to get to a TTY after my Xorg & Yaboot conf fiasco . . . no dice would not open a TTY shell . . . .

F/e.e.p.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/lubuntu-users/attachments/20150512/7e427c95/attachment-0001.html>


More information about the Lubuntu-users mailing list