sharing files between Windows XP and Lubuntu

Marlon Ng guikaye at
Tue Mar 24 15:38:40 UTC 2015

Hi guys. This is what I did.

1. sudo apt-get install samba
---- having trouble accessing shared files on Lubuntu system from Windows
XP, so

2. sudo apt-get remove samba (or something like that)
----- the directory etc/samba was still there, so I used sudo to open the
file manager, then deleted that directory. It was deleted without going to
the TRASH.

3. Followed someone's advice to install the samba GUI, system-config-samba.
Installed it through Synaptic Package Manager.

4. When I open it, a window appears for a split second only. GUI could not
be opened.

5. Uninstalled it using Synaptic. Reinstalled. Same thing.

6. Uninstalled and reinstalled using Software Center. Same thing.

I feel it has something to do with installing the non-GUI samba thru [sudo
apt-get install samba], then uninstalling, then installing the GUI version.
Because a similar thing happened to me with ndiswrapper. Installed the
non-GUI, uninstalled, installed GUI, then GUI won't open.

With the ndiswrapper, I ran out of ideas so I just reinstalled the entire
Lubuntu OS, then ndiswrapper worked. But please don't suggest that I do the
same, I'm tired of reinstalling the entire OS just to fix one problem, it
is overkill.

I'm thinking of going to Synaptic, type in "samba" in the search bar,
remove everything that has to do with samba that is currently installed,
THEN installing the GUI samba.

What do you think?

On Fri, Mar 20, 2015 at 6:58 PM, Marlon Ng <guikaye at> wrote:

> Hi guys. I tried sharing files between two desktop computers, one of which
> is running Lubuntu LTS, the other is Windows XP.
> When I'm using Lubuntu on one desktop computer, I'm able to access the
> shared files in Windows XP on the other desktop computer, using this:
> sudo apt-get install cifs-utils
> For vice versa, I used this:
> sudo apt-get install samba
> Windows XP sees the shared folders on the Lubuntu Machine thru "My
> Network", but in order to access the files within those folders, I have to
> type a username and password. I assume this is the password that I use when
> running the sudo command in terminal, correct?
> The problem is even if I type in the username and password, I just can't
> get to the files. The username and password entry box keep coming up.
> Any suggestions?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Lubuntu-users mailing list