Installing Epson 355 on Lubuntu

Marlon Ng guikaye at
Sun Mar 1 10:09:24 UTC 2015

Sorry, Epson L355 still not working.  When I try to print, paper feeds but
comes out blank; printer doesn't print.  Tried on both Libreoffice Writer
and Calc.  Both failed.

Also, when I click on Image Scan (iscan), I get this message:
Could not send command to scanner.  Check the scanner's status.

I believe the printer and scanner drivers for L355 is the same for L210,
correct? My L210 is working fine (printer and scanner).  Having trouble
with L355 only.

I don't know if I installed it correctly, but when I click Printers, then
double click on EPSON_L355_Series icon, under Settings I see:
Make and Model:  Epson 9-Pin Series.

I forgot if this happened thru CUPS (I don't remember going thru with
choosing 9-Pin Series).

Could this be the source of the problem? How do I fix it?

Thank you.

On Sun, Mar 1, 2015 at 5:17 PM, Marlon Ng <guikaye at> wrote:

> Scratch that epson L355 problem. Seems to be working now. Thanks!
> On Sun, Mar 1, 2015 at 5:13 PM, Marlon Ng <guikaye at> wrote:
>> Hi guys.  I can't install Epson L355.  I already have the printer and
>> scanner driver on my laptop.  I tried to install it over WIFI and when it
>> comes to the part where I have to choose L355 as the model, there's no L355
>> !
>> Your help would be much appreciated.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Lubuntu-users mailing list