getting root setup and opening ftp

Gary Knott garyknott at gmail.com
Thu Jul 23 23:23:31 UTC 2015


Dear Lubuntu group:


1. How do I create a root user that I can login as and
su to for my 14.04 Lubuntu system?   I think it might be:

sudo passwd root
[prompt for my non-root password]
[prompt for root password] (and repeat)

And now root is a proper user with a password.

There is an option for passwd in the man page
:-R CHROOT_DIR   - I don't understand the concept of chroot
very well, but I don't think I want this, right?

(I tried to see if there was an environment variable
called CHROOT_DIR by typing env $CHROOT_DIR.
This typed-out all the environment variables,
and CHROOT_DIR is not there.   But how do I look for
just one such variable as I tried to do?)


By the way the file /root is drwx------, and when
I type 'sudo cd /root'  I get 'sudo: cd: command not found'
It's not an issue of a path for cd, since cd seems to be
built-in.   What's happening?



2.  How do I "open" my 14.04 Lubuntu system (hostname west) to ftp?

I have apt-get installed vsftpd,  and rebooted, now when I log-in there
is a daemon vsftpd running. I can successfully ftp OUT from
west to another "open" linux system, and put and get files.

And I can execute [ftp 204.xxx.xxx.xxx] on another machine
where 204.xxx.xxx.xxx is west's ip number, and successfully
"login" to ftp.  Also I can cd to another directory and I can
'get' a file,  But when I try to 'put' a file, I get
500 Permission Denied.

My home directory on west is drwxr-xr-x

[On our 12.04 KDE system, we "enabled" ftp by
apt-getting vsftpd, adding 'write_enable=YES' in /etc/vsftpd.conf
and restarting vsftpd by typing
'sudo /etc/init.d/vsftpd restart'.

So:

I uncommented  #write_enable=YES in /etc/vsftpd.conf

And then to restart the vsftpd daemon, I typed
sudo /etc/init.d/vsftpd restart    I got 'command not found'.

I have seen the word 'service' somewhere, so I man'ed
service, and then typed
sudo service /etc/init.d/vsftpd restart    I got
"/etc/init.d/vsftpd: unrecognized service"

Then I man'ed 'systemd", but there was no man page.

How do I do the equivalent
of sudo /etc/init.d/vsftpd [option]  now?

Thanks, gary knott,   garyknott at gmail.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/lubuntu-users/attachments/20150723/fe72032b/attachment.html>


More information about the Lubuntu-users mailing list