Fwd: [Lubuntu-admins] 15.04 - Installation Experience

Aere Greenway Aere at Dvorak-Keyboards.com
Sun Apr 26 19:59:06 UTC 2015


On 04/26/2015 11:51 AM, Nio Wiklund wrote:
> Did I understand correctly, that installing systems will overwrite the
> boot sector of the installer (the USB pendrive)? Had you used Unetbootin
> to make those USB systems?
>
> Installing systems should write the bootloader to only one target, and
> it should be possible to select it with 'Something else' (or be on the
> same drive as the root partition). When it happened, was the bootloader
> also written to the internal drive or only to the USB pendrive?
>
> I think this should be no problem with the read-only file system you get
> when you clone the iso file with dd or wrap safety into that process
> with mkusb.
Nio:

The problem happened to me twice, and appeared (each time) after using 
the USB drive to install a system on the hard-drive of another machine.

Both times I built the USB drive using unetbootin, with 4000 GB of 
persistent space on the drive.

With both USB drives it happened to, I first ran it live successfully on 
multiple machines.

The first time I tried to boot the USB drive after using it to install a 
system, I encountered the problem.

The symptoms are, you get the first unetbootin screen, and choose the 
"try lubuntu without installing" option.  Soon after that, you get a 
screen-full of a kernel-panic error (the particulars of which I don't 
remember, as I would have to write it all down by hand at that stage).

I booted LXLE Linux (12.04) after that (it was on my 'old LTS 
partitions' machine), and using gparted, tried to repair the drive. In 
the details of the repair attempt was something about the boot sector 
not matching its backup, and that it would not attempt to repair that.

After doing that 'repair', it still wouldn't boot.  I had to re-build 
the USB drive using unetbootin, after which it worked again, running on 
more than one machine.  When I finally used it to install a system on 
another machine, the next time I tried to boot it, I got the same 
symptoms (kernel panic).

-- 
Sincerely,
Aere




More information about the Lubuntu-users mailing list