On Lubuntu 14.04, No Wireless on 2 machines that wireless worked on 13.10

Aere Greenway Aere at Dvorak-Keyboards.com
Thu May 8 20:06:46 UTC 2014

Pierre & Nio:

I tested several things.

First, I selected (from the main menu) "Preferences"..."Network 
Connections", which brought up a configuration tool that allowed me to 
successfully configure my wireless network.

The nm-applet in the task-bar (inserted by right clicking on the panel) 
shows the connected network, but it is the version (without 
root-permissions) that can't do anything useful.

But the network worked, and I was able to install Lubuntu 14.04 

On re-booting the installed system, there was no wireless because of the 
lack of the b43 installer package.

So to get network access to install the b43 package, I plugged in the 
wireless dongle, and used Nio's method (running from a terminal), which 
put the network applet in the task-bar, and it was the good version, so 
I could configure it.

I installed the b43 Installer package, then re-booted.

On rebooting, there was no network applet in the task-bar, so I used 
Pierre's method to insert it (and now it appears in the task-bar after 

I then downloaded updates, and everything is working fine.

I prefer Pierre's work-around, because it is permanent, and is easier to 
document for users than Nio's method.

If this problem is fixed before Lubuntu 14.04.1 comes out (in July?), 
will the ISO image downloaded include the fix, or will users have to 
work-around the problem for the life of 14.04?

- Aere

On 05/08/2014 11:05 AM, Pierre Gobin wrote:
> Le 08/05/2014 18:49, Nio Wiklund a écrit :
>> 2014-05-08 18:31, Aere Greenway skrev:
>>> On 05/08/2014 03:47 AM, Nio Wiklund wrote:
>>>> When you started nm-applet (and it wouldn't work), did you run it with
>>>> or without gksudo? Try with gksudo, if it you didn't.
>>> Nio:
>>> I would tell you precisely, but I can only reproduce the problem by
>>> running the live CD or live USB, and on those (test) systems, I don't
>>> have access to my e-mail when I do that.
>>> I did not use a command-line interface to access it (I avoid that if at
>>> all possible).
>>> I right-clicked on the panel (in an area without any icon, and chose
>>> "Add/Remove Panel Items" from the pop-up menu.
>>> I then clicked the "Add" button of the "Panel Preferences" window that
>>> appeared (with the "Panel Applets" tab selected).  I don't normally 
>>> have
>>> to do this, because the network (or wireless) icon is already in the
>>> panel when the live CD (or USB) finishes booting.
>>> I then selected "Manage Networks" from the list of available plugins,
>>> and clicked the "Add" button.
>>> I then selected "Network Status Monitor" from the list of available
>>> plugins, and clicked the "Add" button.
>>> Then I fumbled around with those additional applets, right or left
>>> clicking on them, and in one combination, I actually got a list of
>>> wireless networks, of which I selected my network, and tried to connect
>>> to it (by clicking on it?).
>>> A simple dialog appeared, asking me to enter the "Encryption key" in a
>>> text box, which I carefully typed in (because I can't see what I'm
>>> typing), and hit the enter-key (or clicked the button to process the
>>> information).
>>> Nothing appeared to happen.  There was no error message, but the 
>>> network
>>> did not connect, and the icon didn't change in any way indicating it 
>>> was
>>> trying to connect.
>>> With that not working, I specified "System Tools" (or maybe it was
>>> "Preferences") from the task-bar menu, and then selected "Network
>>> Connections" (or something like that).
>>> That yielded a simple dialog with 3 tabs, and nothing like what I've
>>> used in the past to configure a wireless network.  In that simple
>>> dialog, I did not discover anything that would let me configure a
>>> wireless network.
>> Hi again Aere,
>> It works for me with
>> gksudo nm-applet &
>> from a terminal window in Lubuntu 14.04 LTS. This is 'a tweak' included
>> in the OBI tarball described here
>> http://ubuntuforums.org/showthread.php?t=2172971&p=13016768#post13016768
>> Best regards
>> Nio
> I saw many users with problems to connect to networks after running 
> "nm-applet" with root permissions.
> To have nm-applet at startup, I only added "nm-applet" in "Default 
> apps for LXSession", in the tab "Autostart". This solved the problem.
> Regards,
> Pierre Gobin


More information about the Lubuntu-users mailing list