Commit bisect lubuntu-desktop?

John Hupp lubuntu at
Thu Feb 13 00:47:44 UTC 2014

I have been troubleshooting a problem that appeared between Lubuntu 
Raring and Saucy. The problem does not appear on plain Ubuntu. I 
installed lubuntu-desktop on Ubuntu Saucy and duplicated the problem, so 
it seems that something in the desktop environment is responsible. If I 
were speculating, I would say that lxsession or one of its dependencies 
is the culprit.

In any case, after coming at it from a number of angles and not finding 
a solution, I'm wondering about something nice and methodical like a 
commit bisect. Can I do that with lubuntu-desktop or its major dependent 



P.S. I've posted more directly about the problem here, but because it 
involves LTSP and that is a rarity on Lubuntu, no one with specific 
experience addressed the problem (though Israel took a swing at it based 
on his general knowledge). Nonetheless, my notes about what I've tried:

Under Saucy i386, I find that on a client machine the X session ends 
within seconds and returns to the LDM login screen.

LDM.log merely notes something like "x session started" and then 
immediately follows with "x session ended."

It doesn't matter which user account I log in with.

I have tried a couple different clients with different video cards, one 
an old Intel and the other a current Radeon, both with plenty of RAM.

The problem only appears with Lubuntu Saucy. I have not seen it with 
Ubuntu Saucy.

The problem did not appear under Lubuntu Raring.

On an installation of Ubuntu Saucy, installing lubuntu-desktop and 
choosing the Lubuntu session from the LTSP client manifests the bug. 
This heavily implicates LXDE.

~/.config/lxsession/Lubuntu/desktop.conf for both users has 
disable_autostart=all, so many/most autostart apps are disabled.

Disable zram: On the server, sudo mv /etc/init/zram-config.conf –> 
zram-config.donotstart and then sudo ltsp-update-image -c /. Did not fix.

Trying different monitors on the client did not fix.

Check /var/lib/tftpboot/ltsp/i386/lts.conf: LDM_DIRECTX = True (for no 
encrypted SSH tunnel)

cat /var/log/Xorg.n.log on client: I don’t see anything. Last line is 
Suspending AIGLX clients for VT switch.

LTS.conf: LDM_AUTOLOGIN=True (with accompanying user and P/W in specific 
client section) produces a boot loop.

 From LDM, logging in with Session: Failsafe Lxterm produced a 
successful login into a terminal window.
But from that terminal, running startx yields X: user not authorized to 
run the X server, aborting. (Yet it does the same on 13.04, so that does 
not indicate anything.)
On the server, ~/.Xauthority is owned by the respective users, not by 
root (ownership by root had caused this behavior for one user).
None of the users are in the video group, but neither are they in 13.04.

 From LDM on client, Ctrl-Alt-F2 and startx at that root prompt does 
start the Ubuntu X session (though with no desktop features).

More information about the Lubuntu-users mailing list