lubuntu 14.04 ppc errors

Israel israeldahl at gmail.com
Tue Apr 29 12:40:46 UTC 2014


On 04/29/2014 01:45 AM, farinet at arcor.de wrote:
> I sucessfully installed lubuntu 14.04 ppc. That's great.
>
> By far less great is the experience with. Below i list the errors i
> noticed at a first glance (the machine is a pb g4, 1,3 ghz + altivec
> with 2 gb ram):
>
> - Suspend does not work. It only blanks the screen and from that it's
> impossible to wake the pb up.
>
> - the restart in the logout menu of lubuntu does not work
>
> - <Alt><F2> does not work. And alot of other shortcuts as well.
>
> - The macintosh 3rd level chars are not accessable. I did a
>
> 	sudo dpkg-reconfigure keyboard-configuration
>
> (i tried as keyboard Apple and Apple Alluminium; may be i should try
> another one? Which?)
>
> - The combination of xkeyboardmap setting and ibus setting is somewhat
> confusing. Which overrules which one. (On an amd laptop i turned the
> ibus off with no harm, apparently ...).
>
> - Moving windows, even with low charged cpu is dead slow (the windows
> follow the grab like in slow motion (generally the pb is feeling
> absolutely not snappy; in comparison an even older and slower thinkpad
> feels like jet)
>
> - network manager works not correctly. I substituted it by ceni, which
> at least correctly recognizes the b43legacy (eventhough up to now, for
> some reason it does not store the settings and i have to configure it
> newly at any restart.
>
Hi,
Do you have sound?  That is something that doesn't work one of the PPC
machines I have.
If so be glad, the work around involves recompiling a kernel :(

I installed xcompmgr and that seemed to help with moving the windows
around.  (just add it to the startup list)  You can install it and test
it in your session
sudo apt-get install xcompmgr
and test it:
xcompmgr &disown
&disown references the terminal you launch it from disowning it so you
can close the terminal when you want to.

I have not gotten suspend to work on either PPC fully, yet either. 
There may be a work around for it, if it was working in a previous
release.  I am going to test out 12.04 on one PPC to see what works
there, and what doesn't.

WiFi in PPC can be very funny.  In the old Debian install I had I had to
remove the firmware from the installed directory until the computer
decided to randomly to start using the firmware on the internal chip.

Have you tried using xev yet to see if the keys produce any results?
If you are unfamiliar with it, open a terminal and type

xev

Then look at the output starting with

*KeyPress event, *

and find the line with this info:
    state 0x0, keycode 37 (keysym 0xffe3, *Control_L*), same_screen YES,

I pushed the Control key on the left....

You can then map the keys appropriately in your lubuntu-rc.xml file.
Lubuntu doesn't yet have a graphical application for mapping keys.

There was a post earlier about Alt+F2 not working, so you can mark the
bug as affecting you as well.

-- 
Regards

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/lubuntu-users/attachments/20140429/528b7015/attachment.html>


More information about the Lubuntu-users mailing list