Live 14.04 system locks up under heavy I/O with external NTFS-formatted usb2 drives

Nio Wiklund nio.wiklund at gmail.com
Mon Apr 21 19:21:44 UTC 2014


2014-04-21 18:37, Daniel Kulesz skrev:
> Hi folks,
> 
> I was happy to see that Lubuntu 14.04 Live is booting up fine on my
> aged Thinkpad X40 (1,2 GHz Pentium-M with 1GB of RAM). Unfortunately,
> the tasks for which I intended to use the machine are not working the
> expected way. I experienced two failures / bugs:
> 
> - PCManfm is pretty stupid at calculating the remaining time for a
> file operation: when copying one 500 GB file from one connected
> USB2-Drive (ext4) to another (ntfs), it started calculating the
> remaining time for more than 10 minutes (I aborted it then) and it did
> not begin the copy process until then. Seems like it was first trying
> to read the complete file before starting the copy process? Makes no
> sense for me, using "cp" on the command line it worked fine, although
> the system seems to have locked up in the end (completely
> unresponsive) so I had to shut it down by force. Comparing the md5sum
> of the two files, the copy operation seems to have been successful
> though.
> 
> - the system locks up: in a second attempt, I tried to copy around 700
> GB of small files/folders from one connected USB2-Drive (ntfs) to
> another (also ntfs). The copy process went fine for about 20 minutes,
> then there was no visible progress. Switching to command line reveiled
> that 99% CPU was in "wa", and the logs contained some "ntfs driver
> waiting for longer than 120 seconds" messages, together with some
> stack trace. There were about 70MB of memory free though. Logging into
> two consoles and running "uname -a" in one of them left the system
> completely unresponsive, even a reboot was not working anymore.
> 
> Sorry that I have no logs to attach, but I hope this fault can be
> easily reproduced in a virtual environment as well. To me, it seems
> like either the ntfs driver or the usb subsystem seem not to be able
> to work reliably in "low memory" conditions, although I think it's
> debatable if 1GB is really "low". I expect things to be slow, but not
> to lock up!
> 
> Cheers, Daniel
> 
Hi Daniel,

It is possible that you have the same or a similar 'very oldest' Pentium
M at 1.2 GHz, that does not work properly with PAE. Install cpuid and run

cpuid|grep ^00000001

and compare to the result in the following link

https://help.ubuntu.com/community/Lubuntu-fake-PAE#Test

and the only listed item that does not work well with fakePAE.

There might be other problems, for example bad RAM, that can be checked
with memtest at boot, or problems with some other hardware.

Best regards
Nio





More information about the Lubuntu-users mailing list