Israel israeldahl at
Tue Apr 8 12:22:20 UTC 2014

On 04/08/2014 12:49 AM, farinet at wrote:
> Am 07.04.2014 23:52, schrieb lubuntu-users-request at
>> I have never heard of this program before, but when I searched it
>> I found the page you probably know about
>> To compile it seems pretty simple... however, you may need to go in the
>> make file and change some of the dependency names, as Ubuntu/Debian use
>> some very different names for certain libraries.
>> you could open the make file and find the package names, and (simply?)
>> change them to the correct ones.
>> Though, in reality you should probably contact the dev
>> siyan.panayotov at
>> And I think it would be much easier to go about figuring it out this way.
>> So, YES there is a way... this is GNU/Linux there is always a way, some
>> just take a lot of time and effort :D
> Thanks for your reply. Either you've running already lubuntu 14.04 and
> there the libraries needed to compile Viewnior are the right ones or you
> did not really compile it: if you do './configure' you're getting a list
> of files which are not recent enough to create the Makefile. Here is the
> list:
> -------------
> configure: error: Package requirements (gtk+-2.0 >= 2.20
> glib-2.0 >= 2.32              gio-2.0 >= 2.32
> shared-mime-info >= 0.20              gdk-pixbuf-2.0 >= 2.4.0
>     exiv2 >= 0.21) were not met:
> No package 'gtk+-2.0' found
> No package 'exiv2' found
> --------------
> Now, i do not have in mind to do bricolage up to the point to try to
> find somewhere (debian testing maybe) the needed packages. That's the
> reason why i also tried the .deb package of Viewnior i found among the
> Debian packages. But there too i'm getting unfullfilled dependencies
> (the first one: libfontconfig1 is too old).
> I think i'll wait for 14.04 and then retry. Btw, for me Viewnior is a
> really nice and very small imageviewer. Have a look at.
> Thanks again!
Well, I *didn't* try it, but I am *confident *that there is a way to get 
it working.
for gtk2, you probably need something along the lines of
libgtk2.0-dev (just a guess) and something like libexiv2-dev
Unfortunately dependencies can be a problem across Linux platforms 
sometimes as Debian uses its own naming conventions (as do everyone else)
Those files are available, but named differently.  (if you don't need 
the dev files the library has a similar name)
Try changing the names to the equivalent in Debian.  You can always 
search for them using tab completion in a terminal (or use synaptic)
gtk+-2.0 doesn't exist, but exiv2 does... maybe you need to simply use 
all the repositories, and update apt-get.  have you enabled 

14.04 is much quicker anyhow... so it may be worth waiting for it :)


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Lubuntu-users mailing list