How to Change From SNA to UXA Acceleration Methods

Lee Gold leegold at
Thu Nov 7 16:17:02 UTC 2013

On Thu, Nov 7, 2013, at 05:20 AM, NikTh wrote:
> On 07/11/2013 02:04 μμ, Lee Gold wrote:
> > Hi,
> >
> > Using Lubuntu 13.10.  Latest Flash plugin from repositories.
> >
> > I have an Intel Video Chip integrated on my motherboard. It's
> > problematic and there are web pages devoted on how to make it work
> > in Linux. It works OK with Lubuntu except for playing flash on
> > youtube. For example, when trying to play youtube the video appears
> > only green and purple and compressed into a small box. This is a
> > know bug and a "fix" is to change the newer default acceleration
> > method from SNA to the older UXA, then everthing works OK.
> >
> > The only way I know to do this is to generate an xorg.conf file,
> > copy it to /etc/X11 and uncomment the Accelmethod line and edit it
> > to "uxa", then reboot. I did this in Xubuntu previously and it
> > worked. But I cannot get it to work in Lubuntu 13.10. I turn off X
> > and do # X -Confugre to make an xorg.conf file and do as cited
> > above, put it in /etc/X11. But I either get a desktop with a very
> > low resolution that can't be reset to higher normal user resolution
> > or Lubuntu will not boot past the splash screen.
> >
> > So the fix that I see on many website for this is not working - an
> > xorg.conf file to fix is not working. I know xorg.conf is not used
> > anymore but I don't know any other way to fix it permanently.
> >
> > Any help appreciated.
> >
> > Lee G.
> >
> Create an /etc/X11/xorg.conf.d , folder. Then inside this folder
> create a file with name 20-intel.conf
> Inside this file add the following content
> Section "Device"   Identifier  "Intel Graphics"   Driver      "intel"
> Option      "AccelMethod"  "uxa" EndSection
> Save the file.
> Remove any xorg.conf file you have created earlier
> sudo rm /etc/X11/xorg.conf
> Reboot your PC.
> See if this worked
> cat /var/log/Xorg.0.log | grep -i uxa
> Regards NikTh


This did not work. I already tried this but did it again to get the log
info you suggested. Lubuntu boots to black screen with only a mouse
cursor showing. If I somehow get a window open (maybe just a right click
to get a dialog or menu box) and drag it around the desktop with the
mouse then the desktop refreshes and shows up in the swath or path of
the dragged window - from doing this I get most of desktop to reveal -
but the desktop is incomplete. Any Lubuntu/Xfce window or menu I open
has deformed unreadable fonts with missing characters (ie. it's totally
messed-up looking). But if I open Firefox or the terminal it looks and
acts OK though. Here's log output:

user at user1-pchut:~$ cat /var/log/Xorg.0.log | grep -i uxa
[   20.728] (**) intel(0): Option "AccelMethod" "uxa" 
[    21.081] (II) UXA(0): Driver registered support for the following
 user at user1-pchut:~$

Thanks, any ideas appreciated.


-- - A no graphics, no pop-ups email service

More information about the Lubuntu-users mailing list