Did anyone refile bug for Flash Player shows green/purple in compressed window?

John Hupp lubuntu at prpcompany.com
Tue Aug 13 18:46:41 UTC 2013


Here is a fresh summary (with one new result) of the problem on machines 
with integrated Intel graphics in which Adobe Flash Player 11.2 displays 
only with shades of purple and green in a horizontally compressed window.

(My current example is a Dell Dimension 2400 on Raring.)

In my testing with the Intel driver using its default acceleration:
- Flash 11.2 works on Quantal with the 3.5 kernel
- Flash 11.2 works on Raring with the 3.5 kernel **
- Flash 11.8 works on Raring with the 3.8 kernel (in Chrome)
- Flash 11.2 fails on Raring with the 3.8 kernel
- Flash 11.2 fails on Saucy with its default kernel

Disabling Flash *hardware* acceleration altogether (via R-click in the 
Flash display window: Settings: General tab) did not fix the problem.

Setting the Intel driver's acceleration method to UXA rather than its 
default SNA *always* fixes the Flash problem, but causes a garbled login 
screen under LightDM that so far has no workaround.

I also tried one possible fix for the default Intel SNA acceleration 
using the TearFree option.   I created 
/etc/X11/xorg.conf.d/20-intel.conf with contents:
     Section "Device"
        Identifier  "Intel Graphics"
        Driver      "intel"
        Option      "AccelMethod"  "sna"
        Option      "TearFree"    "true"
     EndSection
But this had no effect.

There was a helpful bug report on file at 
http://bugs.launchpad.net/ubuntu/+source/linux/+bug/1178982. (Note that 
it was filed against Linux.)  Workarounds posted there were to change 
the Xorg acceleration method to UXA, or boot with an older kernel.  The 
bug was closed only because the original poster didn't have possession 
of the machine anymore.

------------------------------------------------------------------------

** Flash sort of works in this case.  The colors and window dimensions 
are normal.  But there were other odd display-related effects.  Raring 
booting to a a low-resolution desktop with the mouse pointer locked.  I 
started Chromium via the keyboard and the flash video played long enough 
for me to see normal colors/dimensions, but then it locked up the browser.

In my interest in testing under Raring with an older kernel, I initially 
tried to use a Live USB with persistence and follow the instructions at 
https://wiki.ubuntu.com/Kernel/MainlineBuilds for installing older 
Mainline kernels.  But this failed to install/run properly with the Live 
USB.  And besides, I wanted to use Stock rather than Mainline kernels.  
So I installed a different hard drive, installed Quantal, then upgraded 
to Raring. I suppose if I had run Software Update under Quantal, I would 
have gotten a 3.6 kernel to test as well.  As it was, Raring's Software 
Update did not install a 3.6 kernel, but only the kernel updates proper 
to Raring.

------------------------------------------------------------------------

Looking at the above behavior of the "black box" without nearly enough 
technical knowledge, all I can see at this point is that there is an 
adverse interplay between certain versions of the kernel, the Intel 
driver, and Flash.  (And I grant that I have not documented the versions 
of the Intel driver in the various cases, but no one has given me any 
indication that the Intel driver version is an issue here.)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/lubuntu-users/attachments/20130813/dbe2e5a1/attachment-0001.html>


More information about the Lubuntu-users mailing list