Problem with upgrade of Lubuntu 11.10 to 12.04

Piskie ub.untu at
Mon Jun 18 19:16:11 UTC 2012

On 18/06/12 20:05, Aere Greenway wrote:
> Alex:
> Thank you very much for your quick reply.
> Though I had tried to get qjackctl back after the upgrade (to 12.04) 
> using Synaptic package manager (without success), I hadn't actually 
> tried apt-get (what you suggested), so I quickly tried it.
> As with Synaptic Package Manager, it fails because the upgrade process 
> for Lubuntu marks the package as obsolete.  Here is what happened in 
> my terminal session when I attempted what you suggested:
> aere at aere-Dimension-8200:~$ sudo apt-get install qjackctl
> [sudo] password for aere:
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Package qjackctl is not available, but is referred to by another package.
> This may mean that the package is missing, has been obsoleted, or
> is only available from another source
> E: Package 'qjackctl' has no installation candidate
> aere at aere-Dimension-8200:~$
> As I stated in the e-mail, I had no problem installing it in Lubuntu 
> 12.04 systems that were installed via the install process (rather than 
> the upgrade process).
> Also, it isn't a problem with Ubuntu, because I did an upgrade of 
> Ubuntu 11.10 to Ubuntu 12.04, and the qjackctl package was///not 
> ///marked obsolete, and everything is fine with my upgraded Ubuntu 
> system.
> Since the error message above indicated the problem might be that the 
> required software source was not allowed, I checked the software 
> sources in the Update Manager, but it showed that all of the sources 
> (main, universe, multiverse, and restricted) were selected.
> Unless someone has a way of removing the "obsolete" marking of this 
> package, it appears that my only recourse is to do a fresh install of 
> Lubuntu 12.04, and then install qjackctl.
> I was hoping there might be a way to get the package back without 
> having to re-install the entire system.
> - Aere
Have you tried just downloading the package from

and install from a terminal, after changing to correct location, with

sudo dpkg -i qjackctl

Make sure you have the dependencies installed prior to that.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Lubuntu-users mailing list