Problem with upgrade of Lubuntu 11.10 to 12.04

Aere Greenway Aere at Dvorak-Keyboards.com
Mon Jun 18 19:05:39 UTC 2012


Alex:

Thank you very much for your quick reply.  

Though I had tried to get qjackctl back after the upgrade (to 12.04)
using Synaptic package manager (without success), I hadn't actually
tried apt-get (what you suggested), so I quickly tried it.  

As with Synaptic Package Manager, it fails because the upgrade process
for Lubuntu marks the package as obsolete.  Here is what happened in my
terminal session when I attempted what you suggested:


aere at aere-Dimension-8200:~$ sudo apt-get install qjackctl
[sudo] password for aere: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package qjackctl is not available, but is referred to by another
package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'qjackctl' has no installation candidate
aere at aere-Dimension-8200:~$ 


As I stated in the e-mail, I had no problem installing it in Lubuntu
12.04 systems that were installed via the install process (rather than
the upgrade process).  

Also, it isn't a problem with Ubuntu, because I did an upgrade of Ubuntu
11.10 to Ubuntu 12.04, and the qjackctl package was not marked obsolete,
and everything is fine with my upgraded Ubuntu system.  

Since the error message above indicated the problem might be that the
required software source was not allowed, I checked the software sources
in the Update Manager, but it showed that all of the sources (main,
universe, multiverse, and restricted) were selected.  

Unless someone has a way of removing the "obsolete" marking of this
package, it appears that my only recourse is to do a fresh install of
Lubuntu 12.04, and then install qjackctl.  

I was hoping there might be a way to get the package back without having
to re-install the entire system.  


- Aere

On Mon, 2012-06-18 at 19:10 +0100, Alex Lam S.L. wrote:

> Hi there,
> 
> This seems to be a problem with Ubuntu rather than Lubuntu, which
> relies on the packages provided by the former.
> 
> Either case, looking at the package information, "qjackctl" seems very
> much alive:
> 
>   http://packages.ubuntu.com/oneiric/qjackctl
>   http://packages.ubuntu.com/precise/qjackctl
> 
> And they seem to be of exact same version between 11.10 (oneiric) and
> 12.04 (precise).
> 
> I have also tried installing the package on my system by (under LXTerminal):
> 
>   $> sudo apt-get install qjackctl
>   ...
>   Need to get 14.5 MB of archives.
>   After this operation, 51.5 MB of additional disk space will be used.
>   Do you want to continue [Y/n]?
> 
> So I can't see immediately where the problem is; the system I have
> tested on is a fresh install (instead of an upgrade), but I doubt if
> that would cause any differences.
> 
> Please try the command above - report back with any error messages if
> it fails to install the package.
> 
> 
> HTH,
> Alex.
> 
> 
> 
> On Mon, Jun 18, 2012 at 6:43 PM, Aere Greenway
> <Aere at dvorak-keyboards.com> wrote:
> >
> > All:
> >
> > In testing the upgrade of one of my MIDI-Music systems from Lubuntu 11.10
> > to Lubuntu 12.04, I encountered a serious problem, and in spite of hours of
> > trying, I have been unable to find any way to report the problem (where it
> > does not actually cause a crash).
> >
> > The problem is that the upgrade process for Lubuntu (this problem does not
> > occur in the Ubuntu upgrade), the package "qjackctl" is marked obsolete, and
> > in doing so, after the upgrade, there is no way (that I know of) to
> > re-install it (get it back).
> >
> > The "qjackctl" package is an essential component for people using MIDI
> > music software.  Its absence renders the system useless (or much degraded)
> > for doing MIDI music.  For example, if you use the Rosegarden
> > sequence-editor, you can no longer use audio files in your projects.
> >
> > I have been using qjackctl successfully since I started using Lubuntu, and
> > continue to use it without problems on 12.04 (from a fresh-install).  Given
> > this experience, I find it hard to believe that its presence & use causes
> > problems in Lubuntu.
> >
> > This applies to slower, lower-memory machines (which I always test with on
> > every new level).  I have not had problems with qjackctl, even on a 450
> > megahertz, 384 megabytes ram machine.
> >
> > If qjackctl is no longer allowed on Lubuntu, I will be compelled to
> > abandon the Lubuntu distribution, since MIDI music is most of what I do.
> >
> > Can someone please give me more information on this?  Is there any way to
> > get back qjackctl after it has been marked obsolete?  Why does the upgrade
> > need to declare qjackctl to be obsolete?
> >
> > Thanks in advance for your response.
> >
> > --
> >
> > Sincerely,
> > Aere
> >
> >
> > --
> > Lubuntu-users mailing list
> > Lubuntu-users at lists.ubuntu.com
> > Modify settings or unsubscribe at:
> > https://lists.ubuntu.com/mailman/listinfo/lubuntu-users
> >


-- 

Sincerely,
Aere
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/lubuntu-users/attachments/20120618/09d296ce/attachment.html>


More information about the Lubuntu-users mailing list