(Testing needed) Empty spaces in lxpanel when using xfce4-power-manager

Michael Basse ubuntu at alpha-unix.de
Sun Feb 26 10:13:32 UTC 2012


i can confirm that "my" packages are fixing the issue, plugging on/off 
the ac-adapter is NOT producing empty spaces. So the patch is working


Am 26.02.2012 11:04, schrieb Michael Basse:
> Hi,
> because i am not very familiar with git i have downloaed the
> source-package from 12.04 with apt-get source xfce4-power-manager
>
> i applied the patch and rebuild the package with "dpkg-buildpackage
> -rfakeroot"
>
> You can find the result here
>
> http://alpha-unix.de/~iceroot/ubuntu/xfce4-power-manager/
>
> Because i dont have an amd64 system/cpu i can only provide the i386
> build but i guess that is ok so some of us can test the patch.
>
> Feedback is welcome
>
> Also posted that on the bug.
>
> Kind regards
>
> Michael
>
> Am 25.02.2012 15:58, schrieb Axel FILMORE:
>> I found this :
>> http://git.xfce.org/xfce/xfce4-power-manager/commit/?id=643962eb2d46d48042db0ab278c46813da8b6e9b
>>
>>
>>
>> Maybe it's already fixed, I tried to build it from git :
>> git clone git.xfce.org/xfce/xfce4-power-manager
>>
>> sudo apt-get install \
>> libxfce4ui-1-dev \
>> libxfce4util-dev \
>> libxfconf-0-dev \
>> libxrandr-dev \
>> libdbus-glib-1-dev \
>> libdbus-1-dev \
>> xfce4-dev-tools \
>> libnotify-dev
>>
>> you need also build-essential git autoconf automake and maybe others I
>> forgot :-D
>>
>> ./autogen.sh --prefix=/usr --sysconfdir=/etc --disable-panel-plugins
>> --enable-debug
>> make
>> make install
>>
>> But now x-p-m is no longer running when I resume... so I don't know if
>> it works.
>> I can't find any errors in the logs.
>>
>> :)
>>
>> On 25/02/2012 00:28, Michael Basse wrote:
>>> Maybe someone can give me a hint about debugging on something like
>>> that? sometimes i saw programs having a "dpg" extension. Is that a way
>>> to debug something like that? At the moment i only know strace.
>>>
>>>
>>> Maybe i should call "lxpanel" with strace and do some "ac adapter
>>> on/off" actions to get some usefull output. But if someone of you has
>>> another/better idea on how to debug stuff like that, any feedback is
>>> welcome.
>>>
>>> Kind regards from Germany
>>>
>>> Michael
>>>
>>> Am 08.02.2012 00:32, schrieb Michael Basse:
>>>> Hi everyone,
>>>> first of all i am sorry to use the mailinglist for bug-posting but i
>>>> guess this bug is a show-stopper (imo)
>>>>
>>>> https://bugs.launchpad.net/ubuntu/+source/lxpanel/+bug/846878
>>>>
>>>> I am out of ideas what i can do. I have opened upstreambugs on LXDE and
>>>> XFCE4.
>>>>
>>>> http://bugzilla.xfce.org/show_bug.cgi?id=8424
>>>>
>>>> http://sourceforge.net/support/tracker.php?aid=3458395
>>>>
>>>> If i would know how to provide a better debug to the upstream-teams i
>>>> would do it. That is the reason hy i put this bug in the mailinglist.
>>>> Maybe we can discuss some possibilities to debug/fix this bug.
>>>>
>>>> I am willing to spent my time on this issue, i just need some hints,
>>>> because i am out of ideas to work on this bug.
>>>>
>>>> Do we have some nice debugging-options for lxpanel? --log 5 does not
>>>> seem to work for me and i cant find other places where to find usefull
>>>> debug-infos.
>>>>
>>>> It would be great if we can kill this bug because its affecting every
>>>> lubuntu-version and (imo) makes it very ugly.
>>>>
>>>> Thank you
>>>>
>>>> Michael
>>>>
>>>
>>>
>>
>>
>
>




More information about the Lubuntu-users mailing list