[lubuntu-devel] Hirsute update/upgrade of 794 packages affects wifi network manager??

Fritz Hudnut este.el.paz at gmail.com
Sat Mar 6 19:35:44 UTC 2021

et al:

Again after rebooting tried to add Broadcom back in Add'l drivers, this
time it errored out.  Went to Muon Package manager and searched
"bcmwl-kernel-source" and found it was "installed" . . . tried to
"reinstall" it, but got an error as well.

Went to try to install synaptic to see if it would show or do anything more
via console and it showed:

[CODE] Setting up synaptic (0.90.2) ...
Setting up bcmwl-kernel-source ( ...
Removing old bcmwl- DKMS files...

Deleting module version:
completely from the DKMS tree.
Loading new bcmwl- DKMS files...
Building for 5.10.0-14-generic
Building for architecture x86_64
Building initial module for 5.10.0-14-generic
ERROR: Cannot create report: [Errno 17] File exists:
Error! Bad return status for module build on kernel: 5.10.0-14-generic
Consult /var/lib/dkms/bcmwl/ for more
dpkg: error processing package bcmwl-kernel-source (--configure):
 installed bcmwl-kernel-source package post-installation script subprocess
returned error exit status 10
Setting up libextutils-pkgconfig-perl (1.16-1.1) ...
Setting up libcairo-perl:amd64 (1.109-1) ...
Setting up libglib-perl:amd64 (3:1.329.3-1build1) ...
Setting up libcairo-gobject-perl (1.005-2build1) ...
Setting up libglib-object-introspection-perl (0.049-1build1) ...
Setting up libgtk3-perl (0.038-1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for libc-bin (2.33-0ubuntu2) ...
Processing triggers for man-db (2.9.4-2) ...
Processing triggers for mailcap (3.68ubuntu1) ...
Processing triggers for desktop-file-utils (0.26-1ubuntu1) ...
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)  [/CODE]

So, wired connection is working, but wifi driver seems busted . . . ???

On Sat, Mar 6, 2021 at 11:11 AM Fritz Hudnut <este.el.paz at gmail.com> wrote:

> et al:
> So on reboot I went & checked wifi and no go.  I went to Add'l Drivers and
> I changed driver settings for Broadcom to "do not use" anf then rather than
> rebooting I tried to again "use the device" and it gave an error:  "
> pk-client-error-quark: Error while installing package: installed
> bcmwl-kernel-source package post-installation script subprocess returned
> error exit status 10 (313)"
> I'll try to reboot and then try again to add it back in.
> On Sat, Mar 6, 2021 at 11:01 AM Fritz Hudnut <este.el.paz at gmail.com>
> wrote:
>> On Sat, Mar 6, 2021 at 9:53 AM James Lockie <bjlockie at lockie.ca> wrote:
>>> I think Broadcom wifi driver is a binary blob (closed source).
>>> Does dmesg show anything?
>>> et al:
>> I ran this, which right now sure if "bcm5974" is "broadcom" or not:
>> [CODE] sudo dmesg | grep bcm5974
>> [    7.233621] input: bcm5974 as
>> /devices/pci0000:00/0000:00:04.0/usb3/3-6/3-6:1.2/input/input10
>> [    7.245991] usbcore: registered new interface driver bcm5974 [/CODE]
>> I'm going to see if I can now get wifi to connect to the home network,
>> which is listed already, it wasn't refreshing to the new job wifi yesterday.
>> But, today, using ethernet there were another "116 packages to upgrade &&
>> 13 new packages" which I ran through . . . rebooting now, etc.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/lubuntu-devel/attachments/20210306/815c8997/attachment.html>

More information about the Lubuntu-devel mailing list