[lubuntu-devel] running update/upgrade in Lu 20.04 . .. grub connections wiped??

Fritz Hudnut este.el.paz at gmail.com
Fri Apr 10 21:35:14 UTC 2020


Did a routine apt update/upgrade today and in the list was "grub" . . . I
didn't notice if anything else relating to "grub" was in there . . . but
toward the end of installing something like 174 packages in the console . .
. a "GUI" window opened saying something, "Grub is confused, where do you
want Grub to go?"  And it showed three lines for the 3 drives I have with
the "[ *]"  sdb box checked . . . sda only has OSX and that "[ ]" was empty
and so was sdc "[ ]" . . . since sdc is where Lubuntu is installed I tried
to check it, but didn't remember how to do that, tab was moving the cursor
. . . arrow was moving it up or down . . . so I hit return . . . and
"Bazinga" the GUI window disappeared, the little man went behind the
curtain . . . and the console finished up its process.  But in actuality I
didn't change anything that the updater was showing me . . . only sdb was
checked and that wasn't changed . . . .

On reboot I tried to get into my "main" EFI boot disk where all of the 5
linux OSs are listed, and, oops . . . a line of errors . . . went to grub
rescue.  I am able to get directly to Lu && U-MATE 20 via their own EFI
disks . . . but the other three I have to use SG2 to get into an old???
Grub window that does load all of the systems, but it won't show up in
normal boot.  I have a somewhat "complicated" set up, but I haven't had any
apt update run in such a way that this special window opens asking me to
target the drive for grub . . . with the result that grub gets broken . . .
from "within"??  Usually it is OSX side that messes up grub.  I then ran
"grub-update" in Lu && U-MATE, got over to the OpenSUSE installs via SG2 .
. . ran Yast Bootloader, ran their console command to "set up grub" when I
do that it finds all of the systems, but trying to boot via grub itself . .
. goes to grub rescue window???  I even ran "update-grub" in Manjaro . . .
but only SG2 is getting me into those installs.

Wha happen mon?  Wha happen?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/lubuntu-devel/attachments/20200410/4bb74c3c/attachment.html>

More information about the Lubuntu-devel mailing list