[lubuntu-devel] [Bug 1288786] Re: pkexec does not launch graphical authentication

tombert 1288786 at bugs.launchpad.net
Mon Nov 11 15:35:21 UTC 2019

The issue still is open in Ubuntu 18 LTS.

pkexec normally opens a graphical login, but when doing a "su -l
<differentuser>" it prints a selection in the terminal. No matter what
user is then selected, the authentication will fail.

You received this bug notification because you are a member of Lubuntu
Developers, which is subscribed to the bug report.

  pkexec does not launch graphical authentication

Status in policykit-1 package in Ubuntu:

Bug description:
  Installed Trusty Tahr Lubuntu Beta1 version and added xubuntu desktop.  In buth desktops, I tried to launch synaptic to install some packages.  If I try to launch from menu, nothing seems to happen.  From a terminal, I ran
    pkexec "/usr/sbin/synaptic"
   and saw that it asks for password in the terminal window, instead of popping up an authentication window like previous Ubuntu version did.  That was why I saw no authentication request when launching from menu..  I have a workaround)launching from Terminal window), but this should be fixed before release.

  ralph at minnie:~$ cat /etc/lsb-release 
  DISTRIB_DESCRIPTION="Ubuntu Trusty Tahr (development branch)"
  ralph at minnie:~$ pkexec --version
  pkexec version 0.105


To manage notifications about this bug go to:

More information about the Lubuntu-devel mailing list