Various problems on a Toshiba m200

Mats Ahlgren mats_a at MIT.EDU
Thu Feb 9 03:16:55 GMT 2006


Hello,

No one's been able to help with these problems on the forums or in  
IRC, and Google yields no useful info after... probably 20-30 hours  
of searching combined. Any help would be greatly appreciated:

	Setup:

Toshiba Portège m200 laptop (with a GeForce FX Go 5200 - appropriate  
kernel modules installed)
using KDE 3.5.0 and with latest ver

	Problems:

1) The boot hangs at "uncompressing linux" for the good part of a  
minute. (If I have the splash screen enabled, it will never get past  
the first step and return to the text screen after the hang.) When I  
removed the 'quiet' boot option, I see:

...
...some lines about ACPI
ICH4: not 100% native mode, will probe irqs later
... some line I didn't have time to read
[4294676.411000] ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
[hang for 1 minute or so]

2) All my login prompts from ctrl-alt-f1 through f6 are all black. I  
think this started after I installed NVidia. Is there a way around  
this? (Oddly I think they're still functioning -- you just can't see  
them.)

3) [most severe and infuriating problem:] My laptop's screen  
periodically goes blank. This happens from time to time when it's  
plugged in (I haven't measured it... sometimes it doesn't happen at  
all.) However, I know this happens every 2 minutes when the computer  
is on battery power. When the laptop's screen goes black, there are  
only two ways I can get out of it: If I hit power, the X server  
crashes; if I hit ctrl-alt-f6, and ctrl-alt-f7, then the screen  
slowly returns to normal, but then Firefox will crash (Firefox crash  
error log: http://www.ubuntuforums.org/showthread.php?t=127198). This  
prevents me from using my computer in class. :-(

This is extremely odd for 3 reasons:

- I've tried to turn off sleep *everywhere* I can find it. Is there  
some place I've missed? Is there an ACPI config file to check? Could  
enabling "laptop mode" support cause this behavior?
- I've checked the BIOS settings: The computer is set to power off  
the monitor on battery mode every 3 minutes, not 2 minutes... I think  
I've disabled BIOS powersaving behavior but the interface is poor and  
I'm not 100% sure.
- "cd /etc/acpi; sudo ./sleep.sh" will sleep the computer perfectly  
well and wake it up fine with the power button -- no problems whatsoever

I've also tried acpi=off and other similar boot parameters; they  
haven't fixed the problem (but I'm not 100% I had the right one).

(Is there some way to debug ACPI? Like append debug output to ACPI  
scripts?)

4) Hibernate doesn't work: the system will try to unhibernate, but  
when it tries to "restore to highmem", the screen gets filled with  
funky graphical artifacts and I have to do a hard reboot.

5) Shutdown doesn't work: the screen will go off and the HD will stop  
being read, but the computer still remains active. I have to do a  
hard shutdown every time.

6) [this isn't a hardware-related problem:] KDE's login manager  
doesn't show the "Greeting" and Logo as selected in KControl. Is this  
normal?

7) [this isn't a hardware-related problem:] The battery kicker applet  
does not show up with kompmgr is enabled; one has to disable it and  
reenable it in KControl to get it to work. Also it doesn't update  
properly: goes from 31% to empty instantly.

8) Might anyone know of a utility that lets one browse for wireless  
networks, much like Windows XP?


Any help would be greatly appreciated.

Thanks,
Mats Ahlgren


P.S.: I'd recommending changing the default boot behavior of Ubuntu  
network detection on laptops. I had to do the following tip posted on  
the net to fix a 1-minute hang every time my laptop would boot up:

sudo update-rc.d -f networking remove
sudo update-rc.d networking defalts 99


More information about the laptop-testing-team mailing list