Dorneles Treméa dorneles at x3ng.com.br
Sat Nov 26 12:55:07 CST 2005


Hello,

> > that totally fixed it, thanks a lot!
> 
> my turn now... ;-)
> 
> It stopped work, again. This time, both Breezy and Dapper
> kernels are presenting the same problem, so I bet in one
> of the recent libc6 / xorg updates... :-(

ok, this was a bit tricky, but I figured it out... ;-)

Follow the problem description bellow:

> $ sudo synclient -l
> Can't access shared memory area. SHMConfig disabled?
> 
> (of course it's enabled...)

The above message was the first hint. Everything was working
but after some package updates, my synaptics touchpad stopped
work, both with Breezy and Dapper kernels and without change
any settings...

So I found a small evidence on Xorg logs:

$ grep synaptics /var/log/Xorg.0.log
(EE) No Input driver matching `synaptics'

This explains why my synaptics settings wasn't making any
effect... the driver wasn't being loaded.

But... why the driver wasn't being loaded? Good question,
I asked that my self a couple of times, until I start checking
for the module location.

$ locate synaptics | grep modules
/usr/X11R6/lib/modules/input/synaptics_drv.o

But wait, why it's at /usr/X11R6/lib/modules instead of the theoric
proper location (/usr/lib/xorg/modules)?

So I checked for the available packages:

$ apt-cache search synaptics xorg
xorg-driver-synaptics - Synaptics TouchPad driver for X.Org server
xserver-xorg-input-synaptics - Synaptics TouchPad driver for XOrg server

Huh? Two packages??? Yep... seems that we got a transition to build
modular packages, but we forget to set some conflict flags to force
the upgrade from xorg-driver-synaptics to server-xorg-input-synaptics
when upgrading other parts from the xorg server.

Manually installing the second package removed the first one, and
solved my problem.

I'm CC'ing Daniel Stone here, as the maintainer of these packages, he
probably know what need to be done... :-)

Resuming:

a) Enable SHMConfig at your X server conf "InputDevice" section

b) After kernel 2.6.14, you have to manually load "evdev" module
before start the X server

c) Double check your Xorg/XFree86 modules location, to make sure
that everything is in the right place

d) Be happy and share information, Google likes it... ;-)

Cheers,

-- 

Dorneles Treméa
X3ng Web Technology




More information about the laptop-testing-team mailing list