"Black" tooltip problem Firefox: 1. Seemingly good workaround! 2. Where is "Colors — KDE Control Module"?

Clay Weber clay at claydoh.com
Sat Jul 2 20:07:52 UTC 2016

On Saturday, July 2, 2016 12:33:02 PM EDT Bas G. Roufs wrote:
> System:  Kubuntu 14.04 LTS together with Firefox 47 and KDE 4.13.3.
> Hello Everybody.
> Late May or early June, an update brought FF46 - with several glitches,
> amongst which the "tooltips" with nearly black fonts at a black background.
> I am sure, this problem is familiar to several amongst you. Recently,
> Firefox upgraded to version 47. No doubt, several problems have been
> solved. But the tooltips are still essentially unreadable.
> An internet research made clear to me that:
> = more people are wrestling with this issue;
> = a bug report already has been written;
> = the problem has been solved in the Firefox coming with *Ubuntu 16.06 LTS.
> However, my first opportunity to upgrade to Kubuntu 16.04 will be a few
> weeks or months later. For the time being, I need at least some temporary
> "workaround". When looking for this, I stumbled upon this blog from
> "AshOnIt":
> https://ashonit.blogspot.nl/2016/06/fix-kde-unreadable-tooltip.html
> "AshOnIt" proposes two seemingly good ways to solve the problem for the time
> being. However, for both methods, we need to use this dialogue:
> "Colors — KDE Control Module"
> I have been looking for this "KDE Control Menu" in SYSTEM SETTIINGS.
> However, I cannot find it there. Also another internet search does not
> bring the clarity I need. The "Color" button available in SYSTEM SETTINGS >
> hardware, points at something else. Is there any other place where I can
> find it? Or can I invoke it via some command line command?
> Thanks for considering this question. Yours.
> Bas G. Roufs.

In the Kmenu, type in "color: in the search box.
Or,  go to System Settings >> Application Appearance (or type "color in the 
search box available there). The problem there, is changing the color changes 
it everywhere in KDE, so it may cause things to look different there.

Another option is to switch to a different gtk3 theme, which can be done in a 
different section under Application Appearance. There are only a couple there, 
but you can easily browse and install different ones, Scratch that , as the 
kde-look website is doing massive upgrade and in the process breaking and/or 
mangling the  Get New Stuff functionality in KDE right now

The problem is the oxygen-gtk theme, which  has not kept up with the move by 
Firefox to gtk3. Things work properly in KDE Plasma 5 in 16.04  basically 
because a completely different theme is used there. In 14.04, I switched to 
the 'default" gtk3 theme and I don't have the issue,or any others present in 
the oxygen-gtk theme

At least there are different ways of addressing this to suit more people.

Clay Weber

More information about the kubuntu-users mailing list