Kubuntu as 'host' and Android as 'guest': any experience at this list?

Clay Weber clay at claydoh.com
Mon Aug 10 13:37:51 UTC 2015

On Monday, August 10, 2015 02:27:45 PM Bas G. Roufs wrote:
> Hello Everybody.
> Is there anybody at this list who: .......
> +...  manages to somehow use some recent version of Kubuntu as as a
> 'host',together with some version of Android as guest?
> +... wants to share his or her experience here?
> If your answer to both questions is 'yes', please, read on.
> The exact version of Android is only of secondary importance to me. At this
> moment, I am trying 'Android 4.4. for the Eee PC Family'. However, I am
> happy to use any other version. The exact way to host Android is also of
> limited importance - at his moment, I am trying VirtualBox. However, I am
> also happy to use  'KDE Connect' or any other method.
> A few times, I  fruitlessly tried to to get started with Android within
> VirtualBox
> along the lines of this manual:
> > http://www.howtogeek.com/164570/how-to-install-android-in-virtualbox/
> Other things possibly useful to know:
> * Host OS: an up-to-date Kubuntu 14.04 LTS system;
> * Guest OS tried so far:  Android 4.4. Kitkat for the 'Eee PC Family'
> * Hardware: Asus Eee PC Flare series, 4 GB RAM, 1.6 Ghz processor,  320 GB
> HD.
> So far, I have been using a few strategies.
> First of all, I simply have been following the standard path way I usually
> follow inside Android: early log-in into my gmail account.
> Additionally, I have skipped the login in the early phase; by choosing  a 
> 'not now' option, I do manage to get into the Android system and even to
> prevent that platform from 'sleeping'.
> However, both strategies fail in the end as soon as I try to sign into my
> Gmail account. One persistent problem prevents me from doing anything
> beyond the sign-in moment. I simply do not manage to  transfer the WIFI
> connection I am using, to the virtual Android system - this prevents me
> from using 'Google Play' - the app repository of Google. Both Kubuntu and
> VB do detect the (WIFI) internet connection I am using, however, Android
> not. According to the manual at 'Howtogeek', the internet connection should
> also work by simply skipping the WIFI turn-on option in Android - however,
> this is not the case.
> At this point, a few questions spring to my mind.
> Is there anything else I can do to go beyond this deadlock?
> Secondly, take a look at the hardware specs I have summarised above. Is
> 'Virtual Box' at all possible at such a machine? Is it perhaps better to
> install Android at one of the empty partitions at my machine?
> Finally for now - so far, I have been trying this version:
> Android 4.4. Kitkat for the 'Eee PC Family'.
> However, I am happy to use any other recent version instead.
> Thanks for considering my questions. Have a nice day.
> Respectfully Yours,
> Bas G. Roufs.
> ========================================
> Bas G. Roufs
> Utrecht, NL, EU.
> E.: bas at basroufs.eu, M./SMS: +31 6 446 835 10.

Are you wanting to run Android as a desktop OS, or are you looking for a 
testing/development environment?

Without any links to what image file you are using or to the instructions you  
used to set up and install it, can I guess from " Android 4.4. Kitkat for the 
'Eee PC Family" that you are using an image from the android-x86 project?

As you are using a eee-pc, have you considered installing the OS directly to 
an sdcard and booting from that, or trying a newer iso image, which seems to 
no longer need a special build for individual computers any longer?

You might simply just need to adjust the virtual machine's network card type 
and/or setting it to "bridged" mode.

Having said all this, I have never used android in virtualbox, or on a pc, 
even my eeepc 701

Clay Weber

More information about the kubuntu-users mailing list