no desktop effects in Trusty

Glenn Holmer shadowm at lyonlabs.org
Sun Mar 30 20:45:40 UTC 2014


On 03/30/2014 01:47 PM, Mark Fraser wrote:
> On Sunday 30 Mar 2014 10:22:45 Glenn Holmer wrote:
>> I have Trusty installed and up to date on a desktop machine, and it
>> won't render some of the desktop effects I normally use (e.g. wobbly
>> windows, magic lamp), either with nouveau or the propreitaty nvidia
>> driver. It's now running the nvidia driver (lsmod shows nvidia and not
>> nouveau) at version 331.38-0ubuntu6. This is not a small machine (Intel
>> i7 @3.6GHz w/8 cores, 16G RAM).
>>
>> The error I see in when clicking the Detail button in systemsettings is
>> "effect requires OpenGL", but both kinfocenter and the Nvidia server
>> settings dialog show OpenGL information. The graphics card is a GeForce
>> GTX650 (kinfocenter shows OpenGL/ES version 4.4.0 NVIDIA 331.38).
>>
>> Is anybody else having issues with this on Trusty? Any advice?
>
> They're working here and I'm using a quad core AMD provessor and Nvidia
> graphics drivers also at 331.38.
>
> You could try changing the compositing type in the advanced tab of desktop
> effects.

Yes, somehow it had been switched to XRender. Switching to OpenGL 3.1 
made them work again.

There was some other funny stuff going on as well... synaptic reported 
broken package "xserver-xorg-video-nouveau". Also, when switching back 
and forth between nouveau and nvidia, at one point the list of drivers 
came up empty. I assumed it was just that a new one was being set up on 
the servers.

Anyway, desktop effects are working in all their glory now.

-- 
Glenn Holmer (Linux registered user #16682)
"After the vintage season came the aftermath -- and Cenbe."





More information about the kubuntu-users mailing list