kded4 crash inside a VM (kvm/qemu)

Glenn Holmer shadowm at lyonlabs.org
Wed Apr 9 19:04:56 UTC 2014

Latest trusty with all updates applied.

We run vnc4server inside our VMs to have tighter control over the port 
number and to be able to access the VNC session from other machines 
besides the host. We've been doing this for some time with Kubuntu 
12.04, but when we first connect to the VNC server of the VM in 14.04, 
we see a segfault from kded4, and some apps like okular won't run 
because of it.

We start vnc4server in the VMs like this:

su $USER1 -l -s /bin/bash -c \
"vncserver :1 -geometry 1024x768 -depth 24 -name $SESSION_NAME" 2>&1

where $USER1 is the name of a user and $SESSION_NAME is the hostname of 
the VM with "1" or "2" appended.

We edit ~/.vnc/xstartup to contain just the single line:

. /etc/X11/Xsession

I tried it also with "startkde" and got the same result.

Is there a better way to do this? Is it a bug? Is there a better place 
to ask? I have a backtrace, but the crash dump reporter is telling me 
it's not useful.

Glenn Holmer (Linux registered user #16682)
"After the vintage season came the aftermath -- and Cenbe."

More information about the kubuntu-users mailing list