"[14.04] KDE Login Error "Could not start dbus. Can you call qdbus?"

Kaj Haulrich kaj at haulrich.net
Wed Apr 9 08:46:56 UTC 2014


On 09-04-2014 03:46, Bernard Gray wrote:
> Hi Guys,
> Me again - the dist-upgrade on my 14.04 machine today yielded a
> complete KDE Desktop failure. After I login (KDM) it drops me to a
> wallpaper screen with a basic xorg window displaying:
>
>   "Could not start dbus. Can you call qdbus?"
>
> ...and an [okay] button.
> The okay button does nothing when you click it, and my desktop is unusable -
>
> The system dbus is running, I assume this is referring to the session
> dbus instance that is not starting. If I run qdbus in a tty:
>
> $ DISPLAY=:0 qdbus
> :1.0
> org.freedesktop.DBus
> $ echo $?
> 0
>
> I've seen one other report of this on an unofficial(?) french ubuntu forum:
> https://forum.ubuntu-fr.org/viewtopic.php?pid=16537651
>
> I'm installing gnome as we speak to get running for now, will happily
> do more troubleshooting if someone can guide me -

This nasty bug hit me this morning, just as I was going to do a lot of 
work. Damn. None of the quirks mentioned in this thread worked on my 
14.04 Kubuntu. So in order to get things done I installed Xubuntu 
alongside Kubuntu:

'sudo apt-get install xubuntu-desktop'

which took about 4 minutes. Rebooted and logged into xubuntu. Everything 
is dandy, and after a few tweaks in the settings-manager (like changing 
the background, adding a panel with my preferred applications etc.) my 
desktop looks (almost) like my usual kde. Back to real work now...

Kaj Haulrich.




More information about the kubuntu-users mailing list