Dolhpin Can't Mount SD Cards From Camera Nautilus Can

Mark Greenwood fatgerman at gmail.com
Wed Jan 11 12:10:09 UTC 2012


On 11 Jan 2012, at 00:14, Marcelo Magno T. Sales wrote:

> Em domingo 01 janeiro 2012, Swapnil Bhartiya escreveu:
>> Hi,
>> 
>> Today I connected my Nikon D7000 camera to Kubuntu and it popped a
>> message to open it with either DigiKam, Dolphin or GwenView. I
>> selected Dolphin but all it showed was some crazy folder which had
>> no content in them. It also did not show the two SD carded in the
>> left pane. I open the camera with Nautilus under Ubuntu and it
>> mounted the cards as simple mass storage. How to use KDE/Kubuntu
>> with my camera?
>> 
>> Swapnil
> 
> I have a Nikon S9100 and Dolphin can't access the SD card when I plug 
> the camera in neither. However, this camera does not function as a card 
> reader when you plug it in. It is not a mass storage device like a usb 
> stick.
> Dolphin tries to access the camera using camera:/ and the device is 
> shown as a "USB PTP Class Camera". However, I can't see its contents in 
> Dolphin, it says "Loading folder" forever and never show the contents of 
> the SD card.
> However, if I remove the SD card from the camera and use a card reader, 
> I can read it in the same USB port.
> Probably it is the same with your camera, but I don't know why Dolphin 
> can't access it directly.
> I have other cameras that behave as a PTP device, but they allow me to 
> configure them as mass storage/card reader, therefore I can read their 
> cards when I connect them to the computer. The Nikon, however,  doesn't, 
> so I always have to read its card using a card reader.

Just to follow up on my comment from yesterday.

Strictly speaking, KDE is doing the right thing. A PTP device is NOT a mass storage device so if you follow the spec to the letter, PTP devices should not be mounted in that way anyway. (However it's one of those cases where the spec doesn't take into account the way people think).

What this means however is that you might find that your camera works with Digikam even though it's not detected by Solid's Mass Storage interface. Have you ever tried firing up Digikam and choosing 'Import'?

Mark


> 
> []'s
> Marcelo
> 
> -- 
> kubuntu-users mailing list
> kubuntu-users at lists.ubuntu.com
> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users




More information about the kubuntu-users mailing list