Oneiric 64-bit and AMD/ATI proprietary drivers

Jose Ildefonso Camargo Tolosa ildefonso.camargo at gmail.com
Wed Jan 11 14:43:22 UTC 2012


On Wed, Jan 11, 2012 at 9:17 AM, O. Sinclair <o.sinclair at gmail.com> wrote:
> On 11/01/12 14:06, Jose Ildefonso Camargo Tolosa wrote:
>>
>> Hi!
>>
>> On Wed, Jan 11, 2012 at 6:24 AM, O. Sinclair<o.sinclair at gmail.com>  wrote:
>>>
>>> Am about to officially give up.
>>>
>>> I have an HP Pavillion dm4 laptop with the dreaded hybrid graphics, in my
>>> case in Intel integrated and an ATI HD5450 "discreet" card.
>>>
>>> On 11.04 I used 32-bit PAE and there it worked. But as I have 4Gb RAM
>>> decided to opt for 64-bit when installing 11.10.
>>>
>>> Most things work well, there are some fairly odd apps that are only
>>> 32-bit
>>> but I have no major problems (except new KDEPIM but that is separate
>>> issue).
>>>
>>> However - installing AMD/ATI Catalyst drivers fail one way or the other.
>>> If
>>> I do from "additional drivers" I just get a message it fails. If I do
>>> from
>>> Muon dito. If I use cli command apt-get or aptitude it can go all the way
>>> to
>>> configuration.
>>>
>>> And that is where I get stuck whether I use downloaded from AMD package,
>>> build packages, run the installer or whatever I do. Have been thru
>>> countless
>>> sites with instructions and forums.
>>>
>>> The last step here is normally "aticonfig --initial -f" with or without
>>> -f.
>>>
>>> I either get an error "PowerXpress error: Cannot stat
>>> '/usr/lib64/fglrx/switchlibGL': No such file or directory" or "no
>>> supported
>>> adapter present".
>>>
>>> So finally my question here: has anyone managed to get the hybrid
>>> graphics
>>> with ATI/AMD working in 11.10 64-bit or are there ohters who have spent
>>> (too
>>> much) time installing and failing?
>>>
>>
>> Yes, I have installed them.  I just installed these packages (using
>> aptitude, should work with apt-get):
>>
>> fglrx-updates
>> fglrx-updates-dev
>>
>> If you tried to install fglrx package from ATI (ie, manual install),
>> you will have uninstall it first, and then cleanup the mess it leaves
>> behind, basically, some broken symlinks... I had a problem with that,
>> after I removed "manually installed" drivers, I was unable to install
>> the official packages.
>>
>> Oh, don't forget to install (if not already installed):
>> linux-headers-generic (or whatever linux-headers you need for your
>> current kernel), remember, this *have to* be the headers for your
>> running kernel, and about any linux-headers will satisfy fglrx-updates
>> dependency, but you need the one corresponding to your kernel, or it
>> will fail.
>>
>> I don't know on your system, but on mine, aptitude shows "duplicated"
>> packages names, it looks like the "duplicated" is the 32 bits version,
>> but I have had odd issues (like conflicts with *a lot* of packages
>> when I try to install most of these), make sure to pick the correct
>> one.
>>
>> Now, I have had bad experiences with so called "hybrid graphics", in
>> my case a ION-based netbook... in the end, I had to disable "discrete"
>> graphics and leave only Intel enabled (because otherwise the netbook
>> would get too hot, and drain battery real fast).
>>
>
> Thanks, unfortunately exactly the same outcome:
>
> "PowerXpress error: Cannot stat'/usr/lib64/fglrx/switchlibGL': No such file
> or directory"
>
> and for sure said "switchlibGL" is non-existent.

Interesting enough, this exists on my system, but here:

/usr/lib/fglrx/switchlibGL




More information about the kubuntu-users mailing list