Bug? with 10.11 Plasma/Plasmoids

Mark Greenwood fatgerman at gmail.com
Thu Nov 17 12:25:01 UTC 2011

I've noticed this. I think there are two bugs.

Firstly I notice on a couple of machines that the internet connection will refuse to come up if I do a 'Restart'. Only a full power-off power-on cycle works. I initially logged a bug about this in the Beta relating to there being no ethernet after resume from sleep but there's been no activity on it from the devs and I gave up. It's a bug in network manager and it was working in the early Betas but got broken about a week before release.

The thing with the plasmoids is trickier to track down. Again, this has only started recently (it doesn't happen on my natty machine running the same version of KDE) so I suspect it's something lower down and not a problem with plasma itself.

In your case your internet connection simply died overnight. I've not noticed this (was it wired or wireless? I don't use wireless as it's been flaky beyond belief since natty). Given what I've uncovered about network manager recently I wonder if your network controller has some kind of power-save mode it slips into after a long period of inactivity -this could potentially invoke the same bug I've found with sleep mode.


On 17 Nov 2011, at 11:54, Nigel Ridley wrote:

> This is 10.11 Oneiric.
> Before I file a bug I want to be able to narrow it down a bit and was wondering if anyone else had noticed the following (or similar):
> Woke up this morning to no internet connection and a dead plasma-desktop (it was black behind a running Thunderbird window). At first I tried 'F2 > plasma-desktop' which sort of worked for a moment then got 'stuck'. I couldn't access the 'logout' feature and resorted to 'Alt + Ctrl + F1' to get to a tty and issued "sudo halt'. I rebooted the laptop, logged in and the plasma-desktop got stuck again with the small 'desktop loading' splash screen stuck in the middle of a half loaded desktop (I could see the kicker bar and a couple of non-kde apps running as well as a couple of [internet accessing] plasmoids. The internet connection was still down. Couldn't do anything - not even 'Alt + Ctrl + F1' so had to hit the power button.
> I tried renaming, from tty1, .kde to kdeOLD and then .kdeGOOD to .kde then logged into kde but still had the same problems. I then decided to start afresh and renamed.kde to kde01, then logged back into a clean plasma-desktop :-)
> When the internet connection came back on I then put things back the way they were with my backup copy of my original .kde (with all my [internet accessing] plasmoids) and everything was OK again.
> So why, when there is no internect connection, and [internet accessing] plasmoids running, does plasma-desktop refuse to load properly?
> Where would I look for a 'bug' and how to reproduce it?
> Nigel
> P.S. Sorry for the long explanation.
> -- 
> kubuntu-users mailing list
> kubuntu-users at lists.ubuntu.com
> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/kubuntu-users

More information about the kubuntu-users mailing list