Kernel update broke Nvidia

Homer fsunoles at
Fri Jan 28 14:08:08 UTC 2011

On Thu, Jan 27, 2011 at 7:59 PM, Goh Lip <g.lip at> wrote:
> On Fri, 28 Jan 2011 04:48:56 +0800, Homer <fsunoles at> wrote:
>> Well, it seems that wasn't the perfect "fix."  I've just noticed I'm
>> getting strange artifacts.  For example, on the on the top left of
>> each window the small icon and push pin are severely scrambled.  Some
>> icons on the panel are also scrambled beyond recognition.  Those
>> issues wouldn't be too bad, but I'm also getting random "blocks"
>> showing up when a new window/application is opened.  I can get rid of
>> those by opening and closing a window over them, but that isn't a good
>> solution.  I tried running nvidia-xconfig again just to see, and I get
>> dumped to a login prompt with the xorg.conf file in place.  I ran the
>> hardware drivers app and it claims I'm running the correct Nvidia
>> driver.
>> I'm certainly no expert at this stuff, but I'm wondering if I'm really
>> running the nvidia drive with the most current kernel.
> Alan made a suggestion about dkms in some earlier thread. It may be good to
> check if the nvidia module is also set up in your new kernel by "dkms
> status". For example in my system, this appears..
> pop at timon:~$ dkms status
> nvidia-current, 260.19.06, 2.6.35-22-generic, x86_64: installed
> nvidia-current, 260.19.06, 2.6.35-23-generic, x86_64: installed
> pop at timon:~$
> If the module does not appear in your new kernel, set it up then. But sorry,
> since I do not have any problem and hence not done this, I am unable to help
> further, but "man dkms" may help. Of course, please let us know how you do
> it so we can learn from you.  :)
> If it is not any problem with dkms, it may help to "sudo update-initramfs"
> and see if this helps.
> Finally, if nothing works, remove the new kernel "sudo apt-get remove
> --purge 2.6.32-28-* when you boot up to the old kernel 2.6.32-27 and then
> update to new kernel one more time.
> Regards - Goh Lip

name at computer:~$ dkms status
nvidia-current, 270.18, 2.6.32-28-generic, i686: installed

I ended up following suggestions here:

I first tried option #3, the Nvidia proprietary way.  The description
claims it is a bit complicated, but works every time.  I followed all
the steps, but it didn't work for me.  I'm sure with effort I could
get it to work, but I moved directly to option #2 instead.  I have the
Nvidia driver working, and the random blocks don't appear.  There is
one scrambled part of the panel though, but I can live with it.  The
button that maximizes the system tray looks like random pixel blocks.
When expanded, the minimize button looks fine.  So at this point I'm
just moving on.

Thanks for all the suggestions.

More information about the kubuntu-users mailing list