Kernel update broke Nvidia

Homer fsunoles at
Thu Jan 27 20:48:56 UTC 2011

On Thu, Jan 27, 2011 at 12:23 PM, Alan Dacey Sr.
<grokit at> wrote:
> On Thursday, January 27, 2011 02:15:34 pm Homer wrote:
>> On Thu, Jan 27, 2011 at 10:51 AM, Alan Dacey Sr.
>> <grokit at> wrote:
>> > On Thursday, January 27, 2011 12:12:02 pm Homer wrote:
>> >> I find a lot of hits with google, but I'm not seeing a solution yet
>> >> that I think is right for my situation.  I just ran an update and the
>> >> kernel updated from 2.6.32-27 to 2.6.32-28.  On reboot I was dumped to
>> >> a command prompt.  Rebooting to the older kernel still works.  Some
>> >> pertinent messages in Xorg.0.log are:
>> >>
>> >> (II) LoadModule: "nvidia"
>> >> (II) Loading /usr/lib/xorg/extra-modules/
>> >> (II) Module nvidia: vendor="NVIDIA Corporation"
>> >>         compiled for 4.0.2, module version = 1.0.0
>> >>         Module class: X.Org Video Driver
>> >> (EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
>> >> (EE) NVIDIA:     system's kernel log for additional error messages.
>> >> (II) UnloadModule: "nvidia"
>> >> (II) Unloading /usr/lib/xorg/extra-modules/
>> >> (EE) Failed to load module "nvidia" (module-specific error, 0)
>> >> (EE) No drivers available.
>> >>
>> >> What is the most straightforward way to deal with the nvidia
>> >> module/drivers after kernel updates?
>> >>
>> >
>> > What probably happened is there is no nvidai driver for the new kernel.
>> >
>> > Did you install the nvidia-current package or did you install it manually?  If you installed it manually, you have to manually update it to the new kernel,  the exact command escapes me at the moment but it's not hard to find (?? nvida-xconfig ??).
>> >
>> > If you installed the ubuntu package then make sure that dkms is also installed, that will compile all nessesary apps for new kernels such as VirtualBox, Nvidia drivers, etc.  I believe that it will run automagically on installation.
>> >
>> > Alan
>> Thanks again for your input on my posts.  The nvidia-current package
>> was already installed.  Was it installed manually?  I'm not sure.  I
>> had some issues with X working soon after a fresh install (10.04), so
>> I may have installed it with aptitude.  I have also verified that dkms
>> is installed.  I also ran the nvidia-xconfig command while booted into
>> the new kernel, and that didn't work.
>> Now, your comments got me considering something.  I renamed xorg.conf
>> to xorg.conf_ and tried booting with the new kernel.  That worked.  I
>> recalled reading something several weeks ago that indicated  it is
>> best to not have a xorg.conf file and just let the system figure
>> things out.  That has worked in my case.  Until the next update
>> anyway...
> I did not know about the xorg.conf thing.  That's my new thing I learned today.

Well, it seems that wasn't the perfect "fix."  I've just noticed I'm
getting strange artifacts.  For example, on the on the top left of
each window the small icon and push pin are severely scrambled.  Some
icons on the panel are also scrambled beyond recognition.  Those
issues wouldn't be too bad, but I'm also getting random "blocks"
showing up when a new window/application is opened.  I can get rid of
those by opening and closing a window over them, but that isn't a good
solution.  I tried running nvidia-xconfig again just to see, and I get
dumped to a login prompt with the xorg.conf file in place.  I ran the
hardware drivers app and it claims I'm running the correct Nvidia

I'm certainly no expert at this stuff, but I'm wondering if I'm really
running the nvidia drive with the most current kernel.

More information about the kubuntu-users mailing list