kubuntu-users Digest, Vol 72, Issue 12

Brian Wootton Brian.Meg at btinternet.com
Mon Jan 10 17:24:20 UTC 2011


On 10/01/11 12:00, kubuntu-users-request at lists.ubuntu.com wrote:
> Re: single user mode (Hans Henry von Tresckow), (Bruce Marshall)

On Sunday, January 09, 2011, Brian Wootton wrote:
 > > It means that from boot-up the single user prompt comes on screen, 
I get
 > > as far as
 > > typing in a userid and a few characters of the relevant passwd then KDE
 > > blots this out with the 'windows' multi-login  box, and I can only log
 > > in to the
 > > full multi-user OS
 > > I see no sign of a grub menu. Aside from this, does 'telinit 1' 
work on
 > > your 64 bit machine?
 > > brian
Don't know why you want to get into single user mode....  you might mention
that.

I just did the following:

booted
got the GRUB menu
did a normal boot
got to the KDM login screen
did a CTL-ALT-F2   (I think I told you  CTL-F2)
got console login prompt
logged in as normal user
did:   sudo  telinit 1

As far as I could tell (there must be a way) I was at runlevel 1.  KDM 
was no
longer running which is a good indication.  Lots of msgs on the screen 
as to
things being shutdown, etc.

Should work.

---------------
Not a hope I'm afraid on my machine - stand by for a long transmission:

KDE multi-user running AOK
cntrl-Alt-F2                       OK
login as root              OK
telinit 1
            |
blue booting up screen with 5 'rotating' dots
            |
hit esc. BEFORE rotating dots stop (when dots stop- no mouse, no 
keyboard - stalled)
        |
'could not write bytes - broken pipe...status 255'
            |
recovery menu
     resume        -> recovery menu(resume)
     clean        -> recovery menu(resume)
     dpkg        -> recovery menu(resume) - had installation CD in drive,
                              just gave a lot of error messages
     failsafex    -> final message on screen is 'will now switch to 
single user mode'
                              only way forward from here was to switch 
off/on on the wall socket
     grub        -> said 'generating .cfg file' then -> recovery 
menu(resume)
     netroot        -> gobbledygook - stopped dead, switch off/on on 
wall to reboot.
     drop to root -> says type root password or cntrl-d to continue, 
cntrl-d lead to
                  switch on wall recovery. root password worked
       |
telinit 1
           broken pipe and back to recovery menu(resume)
       |
     drop to root
       |
      startx
       |
           nearly worked, but no networking, because root not $user
       |

gave up!!

Hope the above makes sense.
The reason I wanted to go into single user mode was because I have been
having the odd flaky boot once or twice a week, the symptoms being
very like a hard drive with a dodgy block in the boot area and I wanted
to do an fsck with various flags to see if anything came up.
  I was bone idle when I installed Lucid and just had the one giant 
partition
shan't do that with Maverick.
I've got 'https://help.ubuntu.com/community/KeyboardShortcuts' but it
doesn't mention the CNTRL-ALT-Fx functions at all, do you know where I can
find them please.
  Thank you very much for your help and advice but don't spend a lot of 
time
on this as I'm going install Maverick shortly - maybe that will make a 
difference.
regards
brian




















More information about the kubuntu-users mailing list