[SOLVED] Re: AMD A4-Series APU A4-3400 compatibility

Jim Cunning jcunning at cunning.ods.org
Sun Dec 11 00:09:24 UTC 2011

On 12/09/2011 10:34 PM, O. Sinclair wrote:
> On 10/12/11 05:45, Mark Greenwood wrote:
>> The ATI proprietary driver is called 'fglrx':
>> [   128.967] (II) LoadModule: "fglrx"
>> [   128.968] (WW) Warning, couldn't open module fglrx
>> [   128.968] (II) UnloadModule: "fglrx"
>> [   128.969] (II) Unloading fglrx
>> [   128.969] (EE) Failed to load module "fglrx" (module does not
>> exist, 0)
>> Your Xorg.log shows that the 'fglrx' driver doesn't exist - it hasn't
>> been installed correctly. X tries to load it and fails so falls back to
>> trying various other drivers (I think it ends up trying the radeon
>> driver or framebuffer mode, I'm no expert in these things), but none of
>> these drivers can handle it. So we need to get it installed properly.
>> Unless you know how to install it from the command line (which I don't)
>> then this means using the Additional Drivers tool.. but that needs X, so
>> we need to get you into X.
>> It's possible that 'nomodeset' may be confusing the various drivers. So
>> we need to see if we can get you into X without using that option. If I
>> take it as read that you can't just boot into X without using nomodeset,
>> then this means bypassing the ****** plymouth splash screen.
>> edit /etc/default/grub: Comment out (with a hash) the line that starts
>> with 'GRUB_HIDDEN_TIMEOUT'. Uncomment the line GRUB_TIMEOUT and set a
>> value, e.g. GRUB_TIMEOUT=10.
>> Now run sudo update-grub, and reboot.
>> When you do this you should see the grub menu at boot. This will allow
>> you to select 'recovery mode'. Do this and then just select 'Continue
>> normal boot'. This bypasses the plymouth splash screen.
>> Try this with or without nomodeset - one way might get you into X from
>> where you can install the ATI driver. Once done you'll again need to see
>> whether you now need nomodeset to get the system to boot properly.
>> The other way to bypass the splash is just to prevent plymouth ever
>> using a splash screen - I haven't tried this myself but in
>> /etc/default/grub you'll see the options 'quiet splash' on
>> GRUB_CMDLINE_LINUX_DEFAULT. You can remove these options, run sudo
>> update-grub again and reboot and you'll get a good old-fashioned very
>> messy looking linux boot up :)
>> I went through all this on a recent NVIDIA system install, so I'll try
>> to help all I can.
>> Mark
>> On 9 Dec 2011, at 23:25, Jim Cunning wrote:
>>> Top-posted, see bottom
>>> On 12/09/2011 03:11 AM, Mark Greenwood wrote:
>>>> It's plymouth. You'll probably find that if you boot into recovery
>>>> mode and then just select 'continue normal boot', you'll boot up just
>>>> fine. Otherwise 'nomodeset' is the way.
>>>> If there are proprietary video drivers for your card, install them.
>>>> It fixed the problem for me.
>>>> Mark
>>>> On 9 Dec 2011, at 01:42, theuteck at gmail.com
>>>> <mailto:theuteck at gmail.com> wrote:
>>>>> My Atom system does something similar. I have to pass 'nomodeset' to
>>>>> grub and
>>>>> and add it to /etc/default/grub to see the video. If I boot into
>>>>> recovery
>>>>> mode I can still see the screen so I can make the edit, so hopefully
>>>>> that is
>>>>> the same for you.
>>>>> On Thursday, December 08, 2011 05:04:38 PM Jim Cunning wrote:
>>>>>> Update: I purchased the product and tried to install 11.04. The
>>>>>> install CD first displays "error: prefix is not set", then grub
>>>>>> gives me
>>>>>> the choice of "Start Kubuntu" or "Check disc for defects"
>>>>>> Regardless of which selection I choose, the screen goes blank, and
>>>>>> eventually the monitor reports "No signal". Despite this, I
>>>>>> believe the
>>>>>> system is booting because I can hear and see CD drive activity. If I
>>>>>> select "Check disc for defects" the drive remains active for
>>>>>> quite some
>>>>>> time, confirming my suspicions. The problem is that the video never
>>>>>> comes back after the initial grub screen.
>>>>>> The behavior is the same with 11.10, however 10.04 LTS does boot,
>>>>>> successfully and install completely. The problem with 10.04 LTS
>>>>>> is that
>>>>>> the video is only 1280x1024 on a 1920x1080 monitor, and eth0 is
>>>>>> recognized and sends DHCP requests, but never receives the responses
>>>>>> from the router. I know the LAN interface works with Windows 7 in
>>>>>> the
>>>>>> remaining partition on the disk.
>>>>>> I also tried installing from a USB stick and got the same results as
>>>>>> with install CDs.
>>>>>> Anyone know what kind of grub/kernel boot parameters I can used to
>>>>>> get a
>>>>>> video display to continue a 11.04 or 11.10 install?
>>>>>> Thanks,
>>>>>> Jim Cunning
>>>>>> On 12/06/2011 09:22 AM, uteck wrote:
>>>>>>> That is one of the new Bobcat or Llano chips., I Googled for
>>>>>>> "ubuntu
>>>>>>> bobcat apu"
>>>>>>> The AMD forum has some good reviews of it working very well with
>>>>>>> 11.04
>>>>>>> http://www.amdzone.com/phpbb3/viewtopic.php?f=532&t=138280&start=100
>>>>>>> <http://www.amdzone.com/phpbb3/viewtopic.php?f=532&t=138280&start=100>
>>>>>>> <http://www.amdzone.com/phpbb3/viewtopic.php?f=532&t=138280&start=100
>>>>>>> <http://www.amdzone.com/phpbb3/viewtopic.php?f=532&t=138280&start=100>>
>>>>>>> On Tue, Dec 6, 2011 at 10:56 AM, Jim Cunning
>>>>>>> <jcunning at cunning.ods.org <mailto:jcunning at cunning.ods.org>
>>>>>>> <mailto:jcunning at cunning.ods.org>> wrote:
>>>>>>> Hello all,
>>>>>>> I am looking at purchasing an Acer desktop computer with an AMD
>>>>>>> A4-Series APU A4-3400(2.7Hz) processor. I assume the CPU itself
>>>>>>> is
>>>>>>> x86_64 compatible, but was wondering about the graphics
>>>>>>> compatibility. I didn't see anything from Google to give me a
>>>>>>> clue. Anyone have experience with this processor? Any caveats?
>>>>>>> Thanks,
>>>>>>> Jim Cunning
>>> There is no "recovery mode" available from grub on the install CD/USB
>>> stick, no "nomodeset" was my only option, and it worked. I installed
>>> 11.10, but somehow Windows 7 screwed up the HDD grub, and I had to
>>> re-install grub from the live CD. OK, so far.
>>> Now the system (11.10) will boot as long as I put in "nomodeset", but X
>>> fails to start and I have only virtual consoles available. I downloaded
>>> the AMD ATI proprietary driver, which had successfully installed on
>>> 10.04 LTS, but it aborts when started from a virtual console.
>>> /var/log/Xorg.0.log has a lot of stuff (of course), but the error line
>>> near the end
>>> (EE) RADEON(0): Chipset: "SUMO2" (ChipID = 0x9644) requires KMS
>>> The entire Xorg.0.log file is available at
>>> http://cunning.ods.org/Xorg.0.log
> Just as a note in this discussion: on 11.10 64bit I am still to
> succeed in installing ATI proprietary drivers. Whether I use the
> version in the repos or download from ATI the installation somehow
> goes wrong. For now I have given up and use the foss drivers. This
> worked fine in 11.04 but there I used the 32bit PAE kernel.
I did figure out that fglrx was not installed, so I let the system boot
to a virtual console, then entered

    sudo apt-get install fglrx

and rebooted after the install, still using "nomodeset", and got a good
KDE login screen and normal login.  I then ran the AMD ATI driver
install and rebooted again.  Now the system boots normally and comes up
with a splash screen and KDE login without "nomodeset"

Thanks to all who responded with advice.

Jim Cunning

More information about the kubuntu-users mailing list