AMD A4-Series APU A4-3400 compatibility

Jim Cunning jcunning at cunning.ods.org
Fri Dec 9 23:25:03 UTC 2011


Top-posted, see bottom

On 12/09/2011 03:11 AM, Mark Greenwood wrote:
> It's plymouth. You'll probably find that if you boot into recovery mode and then just select 'continue normal boot', you'll boot up just fine. Otherwise 'nomodeset' is the way.
>
>  If there are proprietary video drivers for your card, install them. It fixed the problem for me.
>
> Mark
>
> On 9 Dec 2011, at 01:42, theuteck at gmail.com wrote:
>
>> My Atom system does something similar.  I have to pass 'nomodeset' to grub and 
>> and add it to /etc/default/grub to see the video.  If I boot into recovery 
>> mode I can still see the screen so I can make the edit, so hopefully that is 
>> the same for you.
>>
>> On Thursday, December 08, 2011 05:04:38 PM Jim Cunning wrote:
>>> Update:  I purchased the product and tried to install 11.04.  The
>>> install CD first displays "error: prefix is not set", then grub gives me
>>> the choice of "Start Kubuntu" or "Check disc for defects"
>>>
>>> Regardless of which selection I choose, the screen goes blank, and
>>> eventually the monitor reports "No signal".  Despite this, I believe the
>>> system is booting because I can hear and see CD drive activity.  If I
>>> select "Check disc for defects" the drive remains active for quite some
>>> time, confirming my suspicions.  The problem is that the video never
>>> comes back after the initial grub screen.
>>>
>>> The behavior is the same with 11.10, however 10.04 LTS does boot,
>>> successfully and install completely.  The problem with 10.04 LTS is that
>>> the video is only 1280x1024 on a 1920x1080 monitor, and eth0 is
>>> recognized and sends DHCP requests, but never receives the responses
>>> from the router.  I know the LAN interface works with Windows 7 in the
>>> remaining partition on the disk.
>>>
>>> I also tried installing from a USB stick and got the same results as
>>> with install CDs.
>>>
>>> Anyone know what kind of grub/kernel boot parameters I can used to get a
>>> video display to continue a 11.04 or 11.10 install?
>>>
>>> Thanks,
>>> Jim Cunning
>>>
>>> On 12/06/2011 09:22 AM, uteck wrote:
>>>> That is one of the new Bobcat or Llano chips., I Googled for "ubuntu
>>>> bobcat apu"
>>>> The AMD forum has some good reviews of it working very well with 11.04
>>>> http://www.amdzone.com/phpbb3/viewtopic.php?f=532&t=138280&start=100
>>>> <http://www.amdzone.com/phpbb3/viewtopic.php?f=532&t=138280&start=100>
>>>>
>>>> On Tue, Dec 6, 2011 at 10:56 AM, Jim Cunning <jcunning at cunning.ods.org
>>>>
>>>> <mailto:jcunning at cunning.ods.org>> wrote:
>>>>    Hello all,
>>>>
>>>>    I am looking at purchasing an Acer desktop computer with an AMD
>>>>    A4-Series APU A4-3400(2.7Hz) processor.  I assume the CPU itself
>>>>    is
>>>>    x86_64 compatible, but was wondering about the graphics
>>>>    compatibility. I didn't see anything from Google to give me a
>>>>    clue.  Anyone have experience with this processor? Any caveats?
>>>>
>>>>    Thanks,
>>>>    Jim Cunning
There is no "recovery mode" available from grub on the install CD/USB
stick, no "nomodeset" was my only option, and it worked.  I installed
11.10, but somehow Windows 7 screwed up the HDD grub, and I had to
re-install grub from the live CD.  OK, so far.

Now the system (11.10) will boot as long as I put in "nomodeset", but X
fails to start and I have only virtual consoles available.  I downloaded
the AMD ATI proprietary driver, which had successfully installed on
10.04 LTS, but it aborts when started from a virtual console.

/var/log/Xorg.0.log has a lot of stuff (of course), but the error line
near the end

    (EE) RADEON(0): Chipset: "SUMO2" (ChipID = 0x9644) requires KMS

The entire Xorg.0.log file is available at http://cunning.ods.org/Xorg.0.log

Jim




More information about the kubuntu-users mailing list