near disaster averted - "can not find /dev/by-id/xxxx"

O. Sinclair o.sinclair at
Wed May 19 15:53:22 UTC 2010

Michael Hirsch wrote:
> On Wed, May 19, 2010 at 8:54 AM, Goh Lip <g.lip at> wrote:
>> O. Sinclair wrote:
>>> Goh Lip wrote:
>>>> On Wed, 19 May 2010 14:40:13 +0200
>>>> "O. Sinclair" <o.sinclair at> wrote:
>>>>> Have no idea what happened but if this helps someone landing in the
>>>>> same trouble then it is worth the effort of documenting it.
>>>>> I am still on Karmic with all updates. Last night I was online and
>>>>> left the computer on over the night. No problems, all worked this
>>>>> morning. Shut it down to take it to where I am currently working (it
>>>>> is a laptop and I am currently travelling).
>>>>> On next boot I get to the splash and then I get "BSOD" - Black Screen
>>>>> of Death. A black monitor, no activity or message or anything.
>>>>> Reboot and go to "recovery option" that after a while ends up with
>>>>> the line: ...can not find /dev/by-id/xxxx long string of UUID here
>>>>> I am dropped into Busybox shell and can do nothing worthwhile. I
>>>>> reboot with a usb flash I have and can see that all works and the
>>>>> disks are there (one disk, 3 partitions including swap). I check
>>>>> grub.cfg, I check /etc/fstab and all LOOKS perfect. But no boot.
>>>>> I tried the 3-4 kernels and none worked. Scouted around internet for a
>>>>> solution and there were a few suggestion ranging from rebuilding the
>>>>> kernel to what eventually worked and was simple:
>>>>> on bootup get into the Grub menu by hitting ESC, Shift or both
>>>>> choose a "recovery kernel",  I chose an earlier than the latest just
>>>>> to be on safe side
>>>>> press "e" to get to edit mode
>>>>> replace all UUID-strings with /dev/sda(your root number), in my case
>>>>> /dev/sda2
>>>>> press ctrl+x to boot with those settings
>>>>> drop to a root shell
>>>>> run update-grub
>>>>> reboot
>>>>> all worked as before.... except now grub.cfg points to /dev/sda2
>>>>> instead of /dev/uuid-string
>>>>> Phew,
>>>>> Sinclair
>>>> You've 'sudo update-grub' and grub.cfg shows /dev/sda2?
>>>> Strange.  You may want to double check that.
>>>> But glad you've got this sorted out.
>>>> Regards - Goh Lip
>>> after manually editing the grub as described I dropped to a root-shell.
>>> So no need for "sudo" but update-grub. And yes, following that /dev/sda2
>>> has replaced /dev/uuid-endless-string
>> Sinclair, sorry for being so persistent, but I find that unusual, so I
>> replicated your steps, using older kernel, dev/sdax, recovery mode,
>> root-shell, update-grub (no sudo), reboot and checked the grub.cfg.
> Goh,
> If I understand what Sinclair wrote, he manually replaced the
> UUID-stuff with the appropriate /dev/sdx.  This will certainly work.
> These UUID problems shows once again that labels are often a better
> way to go.  Label your partitions and mount by label.  Labels won't
> change when you expand partitions, etc.
> That said, I don't understand how or why Sinclair's UUIDs got changed.
You did get that right, the edit part of grub menu that made it possible 
to boot and drop to a root shell. Once that edit was done it seems 
update-grub replaced all uuid with /dev/sda2 for whatever reason.

I found the solution at ubuntuforums so I am certainly not the only one 
that has seen this mishap though in most cases it seems like a botched 
update caused it. Since I have made no update for several days and 
rebooted plenty times since I also have no idea whatsoever that caused 
the BSOD.

More information about the kubuntu-users mailing list