nvidia trouble and breaking in a supposedly LTS release

Mark Greenwood captain_bodge at yahoo.co.uk
Mon May 17 18:51:22 UTC 2010

On Monday 17 May 2010 16:54:14 Gene Heskett wrote:
> On Monday 17 May 2010, William Hamra wrote:
> >so after my fresh installation of lucid last week, everything was
> >working like a charm, i had nvidia-current installed, compositing
> >working great, i still am pissed i cant install manually from nvidia's
> >website, but that's fine, as long as ubuntu keep up with the drivers and
> >provide the latest driver. so far so good, except for the nagging popup
> >that i have some updates, which i was delaying since i had better uses
> >for the bandwidth, mainly setting up all my *important* programs, from
> >firefox, to flash, java, thunderbird, vlc, various codecs and amsn.
> >24 hours ago, i decided to update. 100+ megabytes of data got
> >downloaded, and few hours later, the installation started, it included a
> >new kernel, and new nvidia drivers, all went fine. all until reboot.
> >no X, no nvidia modules loaded, no nothing. over the past 16 hours(yes,
> >i haven't slept yet in over 35 hours), i have been trying to fix this,
> >with a combination of dropping to root shells using recovery option,
> >using alternate CD to get a chrooted root shell, and normal booting. i
> >assumed it was the kernel causing this, doing an lsmod showed that
> >ati_agp was loaded as agp_gart, which was just wrong, my motherboard
> >chipset and internal VGA is ATI, but that's disabled since i have a
> >nvidia geforce 8500 installed and plugged to screen. nvidia's drivers
> >still aren't working, and even worse, if a xorg.conf configured for
> >nvidia exists, or there's no xorg.conf at all, the screen goes off as
> >soon as kdm starts, which means i have to blindly go to TTY1, and hit
> >ctrl-alt-del to reboot, and use the alternate CD, because even the
> >recovery option would give the same result, which makes no sense, it's
> >text-mode, why would it do that? i suspect it has to do something with
> >plymouth, but i cant be fessed to mess with that now.
> >eventually, i started checking aptitude changelog for all packages i
> >suspect to have problems, i notice alberto milano patched something in
> >nvidia that deals with the auto-configuration and selection of a VGA,
> >and realized that could be it. i have no idea why he is doing this now,
> >but i find his past work, namely the Envy driver installer far better
> >and stable than his new work for jockey, he could have delayed that to
> >10.10, but no, knowing canonical and ubuntu too well now, they barely
> >care about stability anymore. i dont believe for one, that they dont
> >have a nvidia machine to test on, this is an LTS release, how can they
> >approve such an update AFTER the system was released??
> >i rolled back to the previous nvidia-current package, for some reason,
> >dkms isnot configuring it for the new kernel, but that's fine, i am
> >using the old one now, waiting for some new updates, hopefully sometime
> >this year....
> >sorry for the rant, but this is really unacceptable for a *stable* release.
> I would like to offer a counter rant here Willy.  Installing any card makers 
> binary blob, particularly the nvidia one which has a record of causing nearly 
> 80% of the BSOD's on windows, into an LTS system is equivalent to Daniels 
> being thrown in the lions den.  Only if you were Daniel, would that be 
> construed as safe.  Since neither of us is Daniel, well...
> There are instances where a well working system really doesn't work so well, 
> even if it is stable.  I have about half ati & half nvidia cards in my 
> various boxes, and in order for one of them to actually do its job, which is 
> running a pile of stepper motors attached to my milling machine, and steppers 
> need the steadiest heartbeat to run at anywhere near their maximum speed.  I 
> was having stalls and lockups at any attempted speed about about 2"/minute 
> moves, but nuking all the nvidia stuff and going back to the nv driver 
> allowed me to run at around 11"/minute.  But the mind blower was that when I 
> switched it to the vesa driver, I could reliably move at over 34 IPM.  It 
> turns out the nv driver ran 'better', only by hogging the interrupts, which 
> the vesa driver apparently does not.  And the nvidia driver, by later 
> testing, turned out to be locking out the IRQ's for large fractions of a 
> second, and you cannot expect a stepper turning 400 rpm, to stop in its 
> tracks, and restart back at full speed without a decel/accel ramp so the 
> motor stays locked to the steps.
> Good figures from glxgears is nice for bragging rights, but the real question 
> is, will it do the job?  For this particular job, only the vesa driver works 
> well.  And should I have a problem, dmesg doesn't bitch that my kernel is 
> tainted.

OTOH I will only use nvidia graphics cards in my machines because the binary driver works exceptionally well. I have a fanless 8600GT card which overheats in 30 minutes if used with the nv driver. I have no objections to using nvidia's binary blob, as it provides the graphics performance for which I bought the card as well as the thermal control it needs. I run hard-realtime AV processing, with 2ms audio latency and the bottleneck is not the nvidia driver but the Ubuntu kernel - for which reason I always build my own kernels these days; the nvidia driver does not affect what I do one tiny bit. 

If you're having problems with drivers hogging interrupts this is more likely to be poor motherboard design or a low quality IO chipset (VIA, are you listening?). Indeed if your system has any components made by VIA inside it I would recommend its use as either a doorstop or as filling for your rubbish bin. 


More information about the kubuntu-users mailing list