Upgrade to 10.04 broke wireless.

Kaj Haulrich kaj at haulrich.net
Sat May 8 11:22:05 UTC 2010

Just a note of advice:

The upgrade from 9.10 to 10.04 - followed by re-install x3 - broke my wireless 
completely, wicd as well as network-manager. Everything appeared OK until I 
tried to connect via WPA personal. Then it kept going like this: "Bad 
password" (it wasn't). My network was visible enough, but no go. I tried 
several laptops (Medion Akoyas) with RT2860STA cards - without ever getting 
them to connect. (Bad password). I even tried to install Ubuntu, Uubuntu 
Netbook Remix, vanilla Kubuntu and Kubuntu Netbook Remix - all failed to 

After the downgrade to karmic all is well with wicd. The downgrade procedure 
was as follows:

edit /etc/apt/sources.list and added links to the karmic repositories for the 
universe group.
Did a software update. (sudo apt-get update)
Opened synaptic package manager
Searched for wicd.
Select package -> force version.
Selected version 1.6.1-3.
Applied the update. It downgraded successfully and resolved the relevant 
I then selected package -> lock version.
I edited /etc/apt/sources.list and removed the karmic entries I'd just added.
BINGO:  connected immediately!

Kaj Haulrich.
--- Sent from a 100% Microsoft-free computer---
--------- Running Linux Kubuntu 10.04 ---------

More information about the kubuntu-users mailing list