910 KU live boot CD Graphics fail 6yo Compaq laptop. (jor)

Clay Weber claydoh at midmaine.com
Mon Jan 25 15:30:06 GMT 2010


On Monday 25 January 2010 12:11:24 am giovanni_re wrote:
> Thanks Clay :)  - still some problems, see below:
> 
> On Tue, 19 Jan 2010 10:22:18 -0500, "Clay Weber" <claydoh at midmaine.com> 
said:
> > On Tuesday 19 January 2010 06:01:20 am giovanni_re wrote:
> > > =====  TRYING TO INSTALL KU 910, BUT GRAPHICS PROBLEMS
> > > I'm working to see if I can get KU 910 onto a laptop that runs KU 904
> > > ok (from the alternate, text based installer CD) (there are some minor
> > > existing issues like Kate & some other program occasionally get
> > > rectangles of garbage (typically dots on a black background)), but that
> > > doesn't affect the 910 install issue).
> > >
> > > =====  PROBLEMS:
> > > KU 910 live boots to the GUI desktop display OK except:
> > > 1) the bottom task bar is all black
> > > 2) Mouse over where the K-start button is (LHS) & the popup window is
> > >  garbage (ie, some incorrect graphic, perhaps a hash pattern, perhaps
> > >  random, i don't recall exactly)). 3) left click on where the k-start
> > >  button should be & the menu popup is garage 4) _right_ click on the
> > > k-s button, the popup is correct & readable. Select "classic menu
> > > style" & the menu properly changes to classic, & that menu displays ok.
> > > Further, now the bottom of screen task bar changes from black to gray
> > > garbage (hash pattern?).
> > >
> > > So, maybe this is an X driver issue.
> >
> > I have a 6 year old Compaq Evo N610C, and found the issue with your
> > graphics
> > is a known bug in Karmic
> > https://bugs.edge.launchpad.net/ubuntu/+source/xserver-xorg-video-
> > ati/+bug/426582
> > This issue has been fixed in Lucid
> >
> > To temporarily get your plasma bits working on a live-cd session, you
> > might try enabling desktop effects either via alt-shift-f12, or somehow
> > open a window with a titlebar , right-click on it , go to 'configure
> > window behavior" and enable desktop effects from there
> 
> Clay - you've got exactly the same computer: Compag Evo N610c.  IIRC this
>  has 1GB RAM.
> 
> 1) Boot up, get the desktop background & blacked out bottom bar, right
>  click where KStart button is, select "classic menu style", (now get grey
>  garbage instead of black bottom bar), left click where KStart button
>  should be, classic menu displays, select "settings > system settings", it
>  comes up with garbage top bar, right click that, select "config window
>  behavior", enable check box for "desktop effects", select OK, BUG: Get all
>  black display with white pointer arrow & touchpad no longer works - can't
>  move pointer or do anything - completely locked up, have to power off
>  power on.
> 
> 2) alt-shift-f12 does nothing.  The only key combo with f12 that does
>  anything is ctrl-alt-f12, which gives me a completely garbage screen, same
>  as dong ctrl-alt-f1.  Then ctl-alt-f7 brings me back to the
>  KDE-graphics-desktop display.
> 
> Clay or anyone - further suggestions??
> 
> Thanks :)
> 
As I mentioned, you have to somehow open a window with a (garbled, I know) 
titlebar - try to right-click on your desktop and select 'desktop settings' or 
similar, then right-click on the titlebar and select 'Window Behavior' to 
bring up the plasma/desktop effects config and enable them from there. 

Then see my comment in the report for the xorg.cong file you need to create to 
fix it better and permanently.

EXA is the default acceleration method these days, but on lower-memory gpu's 
don't handle that so well,and performance can be poor (slow) using it. Using 
the settings I found makes it work so much better. I do not recommend playing 
with Desktop Activities, however, as this will seriously bog the 'ole laptop 
down

-- 
Clay Weber
http://kubuntuforums.net
http://flyballmaine.com
http://emacdogsports.com



More information about the kubuntu-users mailing list