Java wants to download an older version
wayward4now at gmail.com
Mon Aug 16 20:11:58 UTC 2010
On Mon, 2010-08-16 at 19:15 +0200, Perry wrote:
> running Karmic Kubuntu and Java 184.108.40.206 I tried to open a .JNLP and got the
> message (translated from French):
> _The application must download an older version of Java
> _Do you want to continue?
> _The required version 1.5+ of Java is not the most recent ...
> I tried to edit a line ( <j2se version="1.5+" /> ) to make it 1.6+ with the
> same result.
> After I mailed to the guy who wrote this .JNLP file, he thought 1.5+ meant all
> versions of 1.5 (not familiar with Java, I cannot agree or disagree on this
> point, but see later...). So he added two resources lines with 1.6+ and 1.7+
> saying it works perfectly on "the server"...but I still had the same message
> *on KUbuntu*
> *I ask this on this list* because on M$, with the same Java version220.127.116.11 I
> had no problem using the first .JNLP file that only mentioned 1.5+
> I had some hits googling, but nothing that seemed promising either as as cure
> nor to help me understand the problem (M$ users also had this message)
> The questions I have:
> 1) Does downloading an older version mean installing it (downgrading)?
> 2) Can I find out which older version the application wants to download?
> 3) Can anyone here provide useful input?
> N.B. I'm pretty reluctant to change anything about Java because it has always
> been quite problematic for me and now it works for all the other stuff I
> checked. For example Installing 1.7 isn't an option because the .JNLP is
> supposed to work from Java 1.5 on.
Can you install the source file and then compile it with ant?? Ric
More information about the kubuntu-users