dependency problem on karmic

Willy Hamra w.hamra1987 at gmail.com
Sat Sep 5 17:48:15 UTC 2009


willy at willy:/etc/init.d$ sudo aptitude install libdvdread4
libavcodec-unstripped-52
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
  libk3b6-extracodecs
The following NEW packages will be installed:
  libavcodec-extra-52{a} libavcodec-unstripped-52
libavutil-extra-49{a} libdirac0c2a{a}
  libdvdnav4{a} libdvdread4 libfaad0{a} libopenjpeg2{a} libx264-67{a}
libxvidcore4{a}
The following packages will be REMOVED:
  libavcodec52{a} libavutil49{a}
0 packages upgraded, 10 newly installed, 2 to remove and 0 not upgraded.
Need to get 5535kB of archives. After unpacking 3682kB will be used.
The following packages have unmet dependencies:
  libk3b6-extracodecs: Depends: libavcodec52 (>= 3:0.svn20090303-1)
but it is not installable
                       Depends: libavutil49 (>= 3:0.svn20090303-1) but
it is not installable
The following actions will resolve these dependencies:

Remove the following packages:
libk3b6-extracodecs

Leave the following dependencies unresolved:
kubuntu-restricted-extras recommends libavcodec52
kubuntu-restricted-extras recommends libk3b6-extracodecs
Score is -281

Accept this solution? [Y/n/q/?] ^C
willy at willy:/etc/init.d$ apt-cache policy libavcodec52
libavcodec52:
  Installed: 4:0.5+svn20090706-2ubuntu1
  Candidate: 4:0.5+svn20090706-2ubuntu1
  Version table:
 *** 4:0.5+svn20090706-2ubuntu1 0
        500 http://archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status
willy at willy:/etc/init.d$

so if i understand correct, libk3b6-extracodecs wants libavcodec52 (>=
3:0.svn20090303-1), meaning version greater than 3.0, right? i have
version 4 installed, so what is the problem here? :S

-- 
Willy K. Hamra
Manager of Hamra Information Systems




More information about the kubuntu-users mailing list