[SOLVED] Re: X falls back to VESA after newest update

Thomas Olsen tanghus at gmail.com
Mon Oct 19 21:56:13 UTC 2009

On 19/10-2009 20:40 Perry <pwhite at bluewin.ch> wrote:
> Le Monday 19 October 2009 13:00:48 Thomas Olsen, vous avez écrit :
> > This morning I got updates for my Intel drivers and I thought that
> > finally I could get rid of some of the bugs and maybe X would enable DRI.
> > After restart I was greeted with a login screen running 640X480 and no
> > way to set it any higher. At the same time the fonts are so fuzzy that I
> > can hardly read what I'm writing.
> [snip]
> Did by any chance this "update" make a backup of your /etc/X11/xorg.conf ?
> Try to find from the date, name and content if there is a suitable file to
>  be renamed as xorg.conf (first rename the actual xorg as xorg.10.19.01,
>  you newer know why). Then restart x (ctrl alt backspace, or better
>  Alt+SysRq+K, or reboot)
> Else read what is in /etc/X11/xorg.conf and see if you can find anything
> there.
> I have been struggling with *my* screen resolution (and my graphical card
> driver) lately but unfortunately my knowledge is too specific and too poor
>  to help you further, I even had to google "DRI" to find out it was "Direct
>  Rendering Infrastructure".
> Whish you good luck		Perry

Hi Perry

Thanks for the the reply. I should have written that I solved the problems. 
First I got X to use the new Intel drivers but they froze up any input 
devices. Then I spent a lot of hours just trying to get the vesa drivers to 
work. Lastly I rolled back to pre-Jaunty Intel drivers[*] and now it's 
snappier than before :-)

[*] https://wiki.ubuntu.com/ReinhardTartler/X/RevertingIntelDriverTo2.4

Best Regards / Med venlig hilsen

  Thomas Olsen

More information about the kubuntu-users mailing list